Optimize ping while giving min/max bandwith



  • some freinds and i are renting a house…
    and have a single cable line comming in (6mbs and 384 k up)

    2 of us just surf the net (one likes to stream vid on occasion)
    one is a constant downloader
    and myself and heavy web browsing and i do alot of LOW latency games (talking sub 15 here...)

    i loaded up PF because our router seems to spaz out when one of us torrented (over heating issuse)

    now that it's running i want it to do more!!! =-D

    i would like to give min gurenteed speed (say 1.5mbs? and 75k up?)

    i figure that would be the easy part....

    now how do i set that up while making sure it moves a particular machine to no.1 priority? (must be lowest latency and be consistant)

    the other users/computers don't care about ping but this machine but act as though it's dirrect connted to modem...

    THANKS!

    *note: ping on this machine was 13 (average when it was just on comp to server to modem)
    now with the torrenting on another machine it's never sub 30.... is that normal? (my CPU is 100% and ram is only 32% is that helps)
    pfsense 1.1
    (pentium2 450 192 ram)



  • You might get better results with a faster machine. Having the cpu pegged at 100% usually means your system is having problems dealing with the load.



  • hrm…

    if it wans'nt pegged at 100% you think the ping would be more steady?

    *grabs a P3 550 from work...



  • Make sure you are not overusing your bandwdith. If you trafficshaper is set too close or even exceeding your real bandwidth it won't do a good job. Try lowering overall up and downstream for your parentqueues to see if you get better results.



  • my connection is SUPPOSED to be 6m/384k
    (cable so no pppoe) (i thinks)

    but i have it set for 5m and 320k

    is this good?



  • I would not trust the advertised settings without benching it. I have seen a lot of lines not having the speed that one would expect.



  • Have you tried using m0n0wall? It has lower hardware requirements and it's traffic shaper works better with online gaming.



  • @Gitsum:

    … and it's traffic shaper works better with online gaming.

    You can't say that in general. From my experience it's not the case but I don't game too much. However I use voip which is latency critical as well.



  • I can say that cause I've tested the crap out of both. Dummynet works better. Sorry.



  • Maybe you can outline the exact steps that you took to test both?  Because I am with hoba.  When the traffic shaper is setup correctly and tuned a bit (from the sticky threads) it works great.



  • See thread;
    http://forum.pfsense.org/index.php?topic=3558.0
    I do keep trying though, with every new release of PFSense. The last test I did, I tweaked my game_upload queue to 75%, priority 7, realtime bandwidth, 550kb. Still drops packets. Even tried setting the ACK flag. I just leave  the traffic shaper off now.



  • Both the game queue and the ACK queues need to be "tweaked" for the amount of bandwidth you have.  Not to over complicate it but there is a excel document in one of the threads that helps in determining these numbers.



  • oh really?

    i put  all the game's ports to a few set of rules us'in the VOIP queues (modified)

    but i can still tell when some-one say…. opens a lage dmp or uploads to the web

    here's what i did:

    LAN->WAN
    TCP  *
    Port: 5001 - 5010  *
    Port: 5001 - 5010  qVOIPUp/qVOIPDown  ultima port set 1

    WAN->LAN
    TCP  *
    Port: 5001 - 5010  *
    Port: 5001 - 5010  qVOIPDown/qVOIPUp  ultima port set 1 2

    LAN->WAN
    TCP  *
    Port: 7775 - 7777  *
    Port: 7775 - 7777  qVOIPUp/qVOIPDown  ultima port set 2

    WAN->LAN
    TCP  *
    Port: 7775 - 7777  *
    Port: 7775 - 7777  qVOIPDown/qVOIPUp  ultima port set 2 2

    LAN->WAN
    TCP  *
    Port: 7875  *
    Port: 7875  qVOIPUp/qVOIPDown  ultima port set 3

    WAN->LAN
    TCP  *
    Port: 7875  *
    Port: 7875  qVOIPDown/qVOIPUp  ultima port set 3 2

    LAN->WAN
    TCP  *
    Port: 8800 - 8900  *
    Port: 8800 - 8900  qVOIPUp/qVOIPDown  ultima port set 4

    WAN->LAN
    TCP  *
    Port: 8800 - 8900  *
    Port: 8800 - 8900  qVOIPDown/qVOIPUp  ultima port set 4 2

    LAN->WAN
    TCP  *
    Port: 9999  *
    Port: 9999  qVOIPUp/qVOIPDown  ultima port set 5

    WAN->LAN
    TCP  *
    Port: 9999  *
    Port: 9999  qVOIPDown/qVOIPUp  ultima port set 5 2

    all have the TOS options ON

    and here's what my VOIP queues looks like:

    25%

    priority 7

    low latency is checked...
    RED , RE I/O
    and ECN

    realtime limit is 256k



  • Try your tests again with the traffic shaper enabled and visit status -> queues.

    Do you see drops on any of the queues besides the default queues?


Log in to reply