N00b Help required : cannot access WAN from VM.



  • I've virtualized pfsense on my linux box and I've followed the vmware tutorial however I don't think its correct for my set up.

    I have a multi nic 1U rack server (8 nics 4x10/100/1000 4x10/100) . My cable modem is plugged directly into  one of the eth4 (vmnet5 if bridged).

    I only have 1 other nic pluged into the 24 port switch this is to the DMZ network and because I can bridge that successfully I see that in the pfsense virtual and I can ping machines on the network range.

    However if I set the virtual network adaptor for the wan to bridge it returns 0.0.0.0.

    I tried setting it to NAT and i get an ip but theres no routing of information between the Guest virtual adaptor and the Hosts adaptor which has the cable modem on it.

    the cable modem provides an ip to the hosts nic and I need the guest to route through that but I'm not sure how to do that. Can someone give me a hand in configuring this as I'm really stuck and I've not found an example that matches my setup up. I keep reading things on NAT and I get more and more confused!

    addtional:
    I wrote this message from the host so I know it has internet access! but I can't ping anything from the virtual as I don't know how to configure the network successfully!



  • ;D its ok i've solved it…

    three issues.

    1. over tired (been network bashing for 14 hrs straight).
    2. impaitent.
    3. no mac address spoofing.

    basically i'd added the mac spoofing originally and not waited for the reload to take effect, not tested a ping and decided it didnt work because the ip still said none...I then messed around with all my vm network settings until i went cross eyed.

    I went through everything again SLOWLY and its working...

    feel a bit of a chump now lol


Log in to reply