Captive portal não desloga os usuários.



  • Boa tarde, estou com problema no CP, após os usuários se logarem nele, ficam sempre logados, o CP não derruba nunca.

    Somente manualmente.

    Estou utilizando a versão 2.1.3

    Agradeço desde já quem puder me ajudar.



  • @gui.ap:

    Boa tarde, estou com problema no CP, após os usuários se logarem nele, ficam sempre logados, o CP não derruba nunca.

    Somente manualmente.

    Estou utilizando a versão 2.1.3

    Agradeço desde já quem puder me ajudar.

    eu atualizei pro 1.4 e agora derruba.



  • Atualizei aqui pro 2.1.4 e continua não derrubando.
    Configurei o hard time out para 600 min mas o usuário fica sempre logado.




  • Nas versões 2.1.3 e 2.1.4 está com esse problema no hard timeout.  Para contornar isso utilize o idle timeout, funciona perfeitamente.
    Versões que eu testei.



  • Aqui não esta funcionando nem idle, nem o hard timeout.

    Como mostra na imagem o idle timeout esta configurado, e quando chego no dia seguinte, continua com todos os usuários logados.



  • Curiosidade: porque usa esses tempo tão altos?

    Obs: não tenho certeza mas vi em algum post passado que alguém fez uns teste com vários tempos e alguns estavam funcionando e outros não.



  • Bom dia !

    Também tive esta dificuldade com os usuários que não estavam se "deslogando" com o parâmetro IDLE ativo.
    Percebi que, ao entrar em STATUS - CAPTIVE PORTAL - Clique em SHOW LAST ACTIVITY, ele abre uma nova coluna nos usuários logados. Nesta coluna percebi que, mesmo o usuário não operar no computador, a sua última atividade era sempre atualizada. Somente ao tirar o cabo de rede percebemos que a LAST ACTIVITY não era mais atualizado. Pressupondo que mesmo com o browser fechado, e sem o usuário tocar no teclado ou mouse, algum outro software mandava algum pacote na rede fazendo com que o usuário permanecesse conectado para o Captive Portal. Talvez o Skype ou algum outro. Então, chegastes a fazer algum teste semelhante ?

    Abraço,
    Marcone



  • Quando for alterar esses parâmetros, reinicie o firewall. Eu utilizo o idle timout de 30 minutos. Se a máquina estiver gerando tráfego em segundo plano, o idle timeout não funcionará.



  • @Tomas:

    Curiosidade: porque usa esses tempo tão altos?

    Obs: não tenho certeza mas vi em algum post passado que alguém fez uns teste com vários tempos e alguns estavam funcionando e outros não.

    Uso o cp com o squidguard, então os usuários logam assim que entram na empresa, e ficam o dia todo logado. Ai quando chegam no dia seguinte, é preciso logar denovo.



  • @neo_X:

    Quando for alterar esses parâmetros, reinicie o firewall. Eu utilizo o idle timout de 30 minutos. Se a máquina estiver gerando tráfego em segundo plano, o idle timeout não funcionará.

    Vou testar reiniciar o fw para ver se pelo menos o idle funciona. Obrigado!



  • em vez de colocar por exemplo .. 120min representando 2 h ..

    coloquei com 119 sem o 0 no final e deu certo !

    coloquei aqui 399 min e está deslogando !



  • @JuniorAndrade:

    em vez de colocar por exemplo .. 120min representando 2 h ..

    coloquei com 119 sem o 0 no final e deu certo !

    coloquei aqui 399 min e está deslogando !

    Obrigado Junior, vou tentar aqui.



  • Aqui mesmo colocando o 9 no final, 599, não deu certo, e reiniciando também não.

    Quando salvo  as configs do CP ele verifica o hard time out e derruba se tiver usuário com mais de 599 min, mas depois não verifica mais.



  • Alguém sabe se tem alguma outra forma de eu colocar por exemplo, no cron, para determinada hora derrubar todos do CP?

    Pelo menos para contornar o problema.



  • marcou a opção

    Reset waiting period on attempted access
    Enable waiting period reset on attempted access |  X |
    If enabled, the waiting period is reset to the original duration if access is attempted when all pass-through credits have already been exhausted.

    abaixo de Waiting period to restore pass-through credits



  • gui.ap

    Como o hard timeout não funciona, tente o idle timeout, coloque um valor baixo tipo 30 minutos. Talvez te ajude. No meu ambiente ficou perfeito.



  • @neo_X:

    gui.ap

    Como o hard timeout não funciona, tente o idle timeout, coloque um valor baixo tipo 30 minutos. Talvez te ajude. No meu ambiente ficou perfeito.

    Vou tentar. Obrigado!