Pfblocker won't start



  • Hello,

    First off, I'm new to pfSense (just started playing with it this weekend) and overall I'm really enjoying the experience.  I'm coming from a dd-wrt loaded wndr3700 (which is now serving as a wifi access point only) and the performance seems noticeably improved (the caching is really nice).

    My problem is I can't seem to get pfblocker to start.  I download, install, and configure pfblocker (following multiple write-ups), but the rules never get created.  Is there some 'trick' to getting pfblocker to start?  Yes I have searched but sometimes knowing the exact search criteria can be difficult.  I had a fit of a time getting squid to start correctly until I found a thread on here where someone had to manually initialize/create the caching.  As soon as I manually created the cache, squid went to working flawlessly.

    Thanks,
    Chris


  • Moderator

    When you define an "alias" and add lists to download, below that is an "action" setting where you need to set for example "Deny Both" which will create deny rules on both the Inbound and Outbound interfaces that you selected on the General settings Tab.

    Hope this helps.



  • Do you mean under the general tab where it says "inbound deny action" and "outbound deny action"?  I have inbound set to Block and outbound to Reject.  I'm using the "Top Spammers" and I have that set to "Deny Inbound".

    Or is there another location I need to adjust?


  • Moderator

    @clsegraves1:

    Do you mean under the general tab where it says "inbound deny action" and "outbound deny action"?  I have inbound set to Block and outbound to Reject.  I'm using the "Top Spammers" and I have that set to "Deny Inbound".

    Or is there another location I need to adjust?

    Yes set the Inbound/Outbound Interfaces on the General Tab, but in the "LIST" Tab, you need to set the "LIST ACTION". It defaults to "Disable". Select one of the options in that drop-down menu.

    This is the same for any of the "Continents" Pages.