After upgrade no nics found in system



  • I upgraded from 2.15 to 2.2 remotely on an intel atom which was running x86 upon reboot it asked my for my vlans and wan etc.

    no matter what i do i get invalid argument supplied for foreach () in /etc/incconfig.console.inc on line 438
    no link-up detected.

    I want to format and reinstall possibly try 64bit but I need to get my config files from this box, and I dont know how considering it's not accepting my nics.

    Does anyone have advice?

    Thanks


  • Banned

    No. Not without information on the hardware involved. Complaining about NICs, yet absolutely no info about them. Hmmm.



  • Hmmm - You already figured this out but I'll say it just incase.  Always backup your config remotely on a separate machine before you upgrade.



  • Here is my specs/

    Supermicro 1U chassis
    Intel ATOM D525MW mainboard w/1GBL
    4GB RAM
    1U PCI lex Riser card
    Intel PCI Gigabit LAN card

    both nics in the machine are intel one built on board the other PCI with riser, I'm trying to locate the but id have to remove it.

    Is there any way to get into the shell and backup the config before I reinstall it?

    upon upgrading I also checked off, backup system before upgrade,  would this help?


  • Banned

    You can go to System - Firmware - Restore full backup to get a working 2.1.5 system back. (Uncheck the "do not restore config.xml" if downgrading.) Once there, produce some relevant info about the NICs. Like, pciconf -lv output.



  • thanks for the info but my delema is I'm on the setup screen asking for my nics.  It's not recognizing them so I dont' have wan or lan therefore I can't html into the gui from a remote computer.


  • Banned

    So stick some other NIC in there that's recognized?



  • bingo thats what I'll do.

    As for my other upgrade the system crashes anytime I try to ssh into it, unfortunately It's remote and I have no access to it.


  • Banned

    Lesson: it takes seconds to back up the configuration before upgrade.




  • Banned

    No idea. All we got from you is you have Intel GLAN and unknown one on your MB.


  • Netgate Administrator

    @fragged:

    Could be this same issue again?

    Unlikely it's completely different hardware. Both systems with that issue were very similar Supermicro servers. The fix hasn't been confirmed on the second box yet either and the symptoms were not identical. We would have to check the logs though.

    Steve



  • So i put another card in was able to boot and get my backup.

    Now upon resintall I booted from my USB key with 2.2 and still can't see the nics. One is buyild on board the other is on a riser.

    I pulled the riser and it's an intel pro/1000 gt dektop adapter

    it also has a number 865080

    This was working flawless on earlier versions on 2.2 no go? is this a freebsd issue?  This is seems to be a common card.

    Anyone know how I can get my current cards to work in 2.2?


  • Netgate Administrator

    Check the boot log, are the cards detected at all? Are there errors shown?
    Read the thread Fragged linked to above. Your hardware is different but do you see the PCI bus memory allocation errors reported there?

    Steve



  • See if it still boots 2.1.5 live image.  Just to be sure nothing has happened to your hardware.


  • Banned

    @nambi:

    So i put another card in was able to boot and get my backup.

    Uhm…. I like... kinda... hoped... you'd restore the backup and use the working 2.1.5 system to finally post some useful info about the NICs. Apparently not the case.



  • Information about the NICs is necessary to offer any useful suggestions.


  • Netgate Administrator

    Well we know that is motherboard is this so we know the on-board NIC, despite it being an Intel board, is a Realtek 8111E. No reason for that to disappear. No reason for either to disappear though. Something more fundamental happening here.

    Steve



  • Boot this thing on 2.15 to see if its a software or hardware problem.

    Or hey…  Lets chat about it a few more days?



  • This is a very strange issue, I booted to 2.1.5 both nics detected without issues. backed up. then I read a post about doing this.

    hint.agp.0.disabled=1
    in loader.conf

    so i reinstalled 2.2 to try, this time my nic were detected. I was able to reboot and get pf sense up and running on 2.2,. i then tried to set the nics up again and sure enough they do no detect.
    but since I had already saved the info pf sense will boot, I also logged in via gui and I can see both nics are online, when i disconnect any of the cat5's they show offline so they are working but if I setup the nics again they fail to detect.

    I would like to alter the loader.config but when I putty into the unit using root and the pfsense path I then go into "shell" I can't seem to locate the the loader.config I can't seem to find the /boot folder

    I can now get this to function but I'm afraid if I ever have to reset the nics, I won't be able to.

    REaltek 8168/1811 onboard and intel pro/1000 GT 82558 chipset on a riser




  • So, run 2.15 abit longer and give the devs a little time to sort it out.

    Try again at 2.21 which I'd assume is as sure to come as death and taxes.


  • Netgate Administrator

    @nambi:

    I was able to reboot and get pf sense up and running on 2.2,. i then tried to set the nics up again and sure enough they do no detect.

    This is a confusing statement. Please define exactly what you mean by 'no detect'. Why did you try to set them up again? Where are you doing that?

    Are you trying to using the auto-detect function at the initial setup interfaces screen? Are the two NICs listed above that as valid interfaces?

    Steve



  • I would like to alter the loader.config but when I putty into the unit using root and the pfsense path I then go into "shell" I can't seem to locate the the loader.config I can't seem to find the /boot folder

    cd /boot
    ls -l loader*
    

    You should put your own changes in loader.conf.local - if it does not already exist, you can easily create an empty one:

    touch /boot/loader.conf.local
    

    You can edit it from the command prompt, if you are happy with that, or just go to Diagnostics->Edit File on the web GUI and load and edit it there.

    And answer the questions from stephenw10 above - we really need to know if it is just the auto-detect up/down stuff that is not working, or if your NICs are not detected at all…



  • I'm up and running (kind of)
    thank you, this problem was so tempermental I really don't understand what fixed it, but I did put the suggested fix in the loader.config.local
    I'm up and both nic are detected.

    I restored from backup the full system (without package info)  but many services from the packages still remained and didn't start. I tried to clean up some old packages that didn't work, by reinstalled ontop then removed them and they came out.

    for some reason my gui is gone and I get a 503 - Service Not Available.  I will reboot and try but I can't do it now too many people already on my back about the downtime.

    I really appreciate the help
    the nics were being detected upon boot but the autodetect was NOT recognizing them, and when I manually entered the name it also wouldn't accept it.



  • loader.config.local

    For reference of future readers, the correct name of this file is:

    loader.conf.local
    

    I guess that nambi has edited the correct file, but just typed the name wrong in the post.



  • yes I did thanks for the correction.