OpenVPN client causes calcru errors or clock skip



  • Heres an odd one. I have pfsense running virtualised (i have tried both Hyper-V and ESXi) and when I enable the OpenVPN client to try and connect to a remote host it causes the system clock to jump forward and back by around 45 seconds to a minute.

    This can be observed in TOP as well as recored in the log files. It also seems to conincide with OpenVPN disconnecting, I am unable to get a stable client connection to many different hosts with different configs. It drops constantly after 20 - 30secs

    My guess is it is related to the calcru issues that seem to impact freebsd vms. I have tried disabling Intel EIST (was always disabled). I have tried adjusting the kern.timecounter.hardware and the kern.hz

    On pfsense 2.2.1, was also doing it prior to the upgrade.
    Intel Core I5


Log in to reply