Non-Transparent squid proxy issue



  • Hi Everyone,

    Before I was using smoothwall and Ipcop. Now, I changed to pfsense.
    I have Just installed pfsense and all required packages. I have setup non-transparent mode proxy so that all user must configure proxy settings on their browsers to access internet.

    But what I see here, few users who has not configured proxy settings on their browsers are still able to access internet.

    Does non-transparent feature not block all internet traffic by automatically if users not configured proxy settings on their browsers ?



  • No.
    (Re)Visit the rules on your LAN interface.  You probably still have the default "allow all" rule in place.



  • What I do is create an alias for the proxy and an alias for the web ports (80, 443).  Then I create an Allow All pass rule at the top for the Proxy alias.  Under that, I put a block rule for All with dest ports being the Web Ports alias.  Save & done.


Log in to reply