PfSense 2.2.3\. Squid reverse proxy with SSL wont work.



  • Hello All,

    I'm trying to get the Squid Reverse proxy to work with SSL, and i have configured it like other configurations i have found on the internet.

    Without enabling the reverse proxy i can access my test site fine at:
    https://imweb11111adm1.mijncomvio.nl:444/portal.html

    With the reverse proxy enabled, it does nothing, and nothing shows up in the proxy or firewall logs.

    Here are the screenshots of my config:

    FW rule:

    Reverse proxy settings(added a working wilcard SSL certificate in pfsense):

    Peer settings(10.30.68.1 is the internal IP address of the webserver):

    Mapping

    Can anyone tell me what i am doing wrong?

    Best regards,
    Joshua



  • I don't know if anything is wrong in term of settings (reading it quickly, it looks ok)
    What I would suggest is that you force FW to log everything and look at FW dynamic view. It will tell you which rule is used.

    Then if Squid is reached, it should log something too isn't it?



  • The firewall log did not show anything, no block and no passes. The reverse proxy log also didnt show everything.

    I noticed the squid service stopped after i selected my SSL certificate. Couldnt start it again until i changed the certificate to the webconfigurator default..

    After that, i am getting an access denied page and a TCP_DENIED/403 in my reverse proxy log. Does this look familiar?

    It is in dutch, but says Access Denied to this page.



  • hi.
    have you managed to resolve this? i'm seeing the same behaviour.