no traffic shaping on NAT forwarded ports


  • I found than shaper per IP works, but if I set external port forward for an IP - pfsense stops shaping this IP - outgoing queue exists but shows only part of traffic.


  • The shaper is stateful, so only new connectionas are assigned to a queue. Reset your states at diagnostics>states, reset state tab, and see if it works like intended after that.


  • @sirocco:

    I found than shaper per IP works, but if I set external port forward for an IP - pfsense stops shaping this IP - outgoing queue exists but shows only part of traffic.

    Need more information for this.

    Version
    Screenshots of the port forward
    Screenshots of the queues and rules

    config.xml and /tmp/rules.debug would be helpful too

    –Bill


  • tcp/udp port forward from external 22105 to internal 192.168.105.105:22105
    some other forwards to 192.168.1.2

    internal network is 192.168.0.0/16

    queues:
    upload:

    name: up105105
    bw = 1%
    priority = 1
    m2= 25kB
    RED,ECN,
    qWanroot

    other filelds are empty

    download: the same as above but
    name: down105105
    m2 is empty
    qLanroot

    rule:
    upload queue - up105105
    download queue - down105105 (I found that specifying here qP2Pdown doesn't work)
    LAN->WAN
    protocol: any
    source: 192.168.105.105 (single host)
    rest of fields are empty/default

    squid is running in transparent mode,

    version: snapshot 25/03/2006

    config-siroccofw1.local-20060405004147.xml.tar.gz.txt