[SOLVED] Wake up On LAN not working



  • Since I have installed my pfSense box (which is running fine) I cannot use the WOL function anymore.

    I have tried to WOL my desktop PC which was able to be woken before I had my pfSense box without problems.
    I have tried with the pfSense webgui, wake me app on my MacBook (wifi), WOL app on my Synology NAS (wired).
    All without luck…

    Anyone have clue what's wrong?

    thanks



  • Anyone?



  • Likely difficult to help without more info.
    Where is the pfSense box in relation to the PC you are trying to wake up?
    Where are the other computers you are using to send the app in relation to the pfSense box and the PC you are trying to wake up?
    Have you done packet captures to ensure the packet is actually getting sent?
    Have you verified that the packet you are trying to send is correctly formed so the PC recognizes it?
    Are you positive that the PC you are trying to wake is actually in a mode that can be woken from and not powered off?

    Draw a picture of your network connections and where you are trying to source the WOL packet from;  that should help you isolate where it could be "lost".



  • Sorry for not providing enough info.

    Attached is a drawing of my network.
    The PC I would like to wake up is the HP DC7700.
    Magic Packets are sent from the pfSense box, the MacBook pro and from the Synology DS412+

    Before I installed the pfSense box it was working without problems.
    I did not change anything except I put the pfSense in front of my network replacing my Ubee modem/router.

    NETWORK DRAWING



  • Sourcing the packet from the MacBook or the Synology does not hit pfSense box in any meaningful sense.  The TL-SG108 should be taking that packet and flooding it out all the ports it did not come in on.
    Sourcing from the pfSense box could get blocked by the TL-SG1005D.

    The WOL packet should be a broadcast packet at the ethernet layer, set up a packet capture on the MacBook and source it from the Synology and see if it actually goes out.  If it does, then you need to look at the HP DC7700;  double check that it is actually in a state it can wake from.



  • Thanks for pointing me in the right direction!
    I have uninstalled the network drivers for the dc7700. Rebooted and reinstalled the latest driver.
    Unchecked the box in the driver Power Management tab: "Allow the computer to turn off this device to save power".
    Doubled checked if "Wake on Magic Packet" was enabled, driver advanced tab.
    Shutdown the DC7700.

    Now it's working!



  • Glad to hear it was that simple.  Power management turning off devices is a subtle thing.

    I always start out by drawing a picture of my network, then walk a packet through it.  When you do that, it usually becomes trivial to find the problem.


Log in to reply