NGINX listens to port 8002 when starting captive portal, breaking it



  • Hi,

    I am on Current base system 2.3.b.20160118.1607

    When I try to start the captive portal, and then go to View Current Page, I just get a blank page on http://localhost:8002

    If I go to syslog I get

    /index.php: Submission to captiveportal with unknown parameter zone:

    I also got an error in the pfsense console saying that port 8002 is already in use

    pfsense nginx: 2016/01/18 22:22:00 [emerg] 88212#0: bind() to 0.0.0.0:8002 failed (48: address already in use)

    If I do a sockstat | grep 8002 I get

    root    nginx      90011 6  tcp6  *:8002                :
    root    nginx      90011 8  tcp4  *:8002                :
    root    nginx      89939 6  tcp6  *:8002                :
    root    nginx      89939 8  tcp4  *:8002                :
    root    nginx      89474 6  tcp6  *:8002                :
    root    nginx      89474 8  tcp4  *:8002                :
    root    nginx      89395 6  tcp6  *:8002                :
    root    nginx      89395 8  tcp4  *:8002                :
    root    nginx      89125 6  tcp6  *:8002                :
    root    nginx      89125 8  tcp4  *:8002                :
    root    nginx      88846 6  tcp6  *:8002                :
    root    nginx      88846 8  tcp4  *:8002                :
    root    nginx      88548 6  tcp6  *:8002                :
    root    nginx      88548 8  tcp4  *:8002                :

    An ideas of what is going on?

    Thanks



  • nginx listening on 8002 is part of captive portal, not something that's breaking it. At least assuming you didn't switch your web interface to use port 8002.

    Is the actual problem just that you can't view your portal login page?



  • Thanks for your reply

    Yes, and also it is not shown to the LAN users

    I tried it restoring a saved config.xml, then tried with a fresh install uploading any captive portal page, no matter what I do, I cannot see the captive portal page

    Thanks again



  • Viewing it via the services_captiveportal.php page is broken at the moment, but captive portal works fine in general (clients will redirect and work fine).

    Clients not redirecting would be one of the usual (no DNS, not permitting the traffic, or similar), see:
    https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting#Captive_portal_not_redirecting

    The bind error at the console suggests you're at least a few days out of date, that no longer happens in the most recent version. Though that error was only cosmetic, it didn't harm anything functionally. Still would be best to make sure you're on the latest version. That'll only make that bind error log go away though, functionally it's likely the same.



  • I fixed the link to display the portal page contents from services_captiveportal.php. The remainder of it works fine.



  • I see you were talking about version amd64, I was trying on i386, which still has the issue. I fixed it adding /?zone="$cportalzonename$" in the cp page.

    Thanks for your quick reply



  • That change applies to both 32 and 64 bit. At the point you tried there might not have been a new 32 bit update yet, but it's available now for both.


Log in to reply