DHCP stopped after adding a second LAN interface



  • Hallo guys.
    I need some help on an issue i am fighting with for the past 6 hour.

    I have 2  /27 subnets from my ISP. The first subnet is on LAN 1 and it is working perfect. The issue is with my 2`nd subnet. So i have configured the second LAN interface and it is working untill i go and activate DHCP on it. At that moment the DHCP service is down and i can1t get it up again untill i deactivate the DHCP on 1 of the interfaces.

    In the System log i get the following:
    php-fpm[90214]: /services_dhcp.php: The command '/usr/local/sbin/dhcpd -user dhcpd -group _dhcp -chroot /var/dhcpd -cf /etc/dhcpd.conf -pf /var/run/dhcpd.pid pcn0 xl0' returned exit code '1', the output was 'Internet Systems Consortium DHCP Server 4.2.8 Copyright 2004-2015 Internet Systems Consortium. All rights reserved. For info, please visit https://www.isc.org/software/dhcp/ Wrote 0 deleted host decls to leases file. Wrote 0 new dynamic host decls to leases file. Wrote 7 leases to leases file. Multiple interfaces match the same subnet: xl0 pcn0 Interface pcn0 matches multiple shared networks If you did not get this software from ftp.isc.org, please get the latest from ftp.isc.org and install that before requesting help. If you did get this software from ftp.isc.org and have not yet read the README, please read it before requesting help. If you intend to request help from the dhcp-bugs at isc.org mailing list, please read the section on the README ….....

    Here are my specs:
    Version 2.2.6-RELEASE (i386)
    built on Mon Dec 21 14:50:36 CST 2015
    FreeBSD 10.1-RELEASE-p25
    CPU Type Intel(R) Celeron(R) CPU 2.80GHz; 2 GB RAM

    LAN1: pcn0
    Subnet 46.214.70.192
    Subnet mask 255.255.255.224
    Available range 46.214.70.193 - 46.214.70.222

    LAN2: xl0
    Subnet 46.214.70.224
    Subnet mask 255.255.255.224
    Available range 46.214.70.225 - 46.214.70.254

    Please help me solve this issue.


  • LAYER 8 Netgate

    Multiple interfaces match the same subnet: xl0 pcn0 Interface pcn0 matches multiple shared networks

    What are your interface addresses?
    Post your actual interface and DHCP server configs screens.



  • Here is the information. If you need something else let me know.
    THANK YOU!



  • LAYER 8 Netgate

    If the interface IP address is on LAN2 is .225, change your pool starting address to .226, enable DHCP on LAN2 and see what happens.



  • I made the change and the result is the same.


  • LAYER 8 Netgate

    Post the actual interface configuration pages.



  • I am new to pfsense so please guide me to the pages that you need


  • LAYER 8 Global Moderator

    so these public networks are actually routed to you?  What is the network on your wan?

    I show this falling under 46.214.68.0/22 Bistrita-Nasaud on AS48161

    You just click the interface name to call up its actual settings.




  • here is the routing…. it is working fine... i am using it. it is just that when i activate the dhcp service on both the lan interfaces.... the service is stopped. when i deactivate 1 of them ... the service is back up



  • LAYER 8 Netgate

    OMFG POST BOTH LAN INTERFACES.



  • here is the second lan



  • LAYER 8 Global Moderator

    that is not routing that is your lan interface.. What is the other interface, and what is the network you have on your wan.  Please post all 3 of them like you just did for lan

    edit: well those clearly do not overlap.. So what is your wan??



  • here is the wan conf page … the ip for it is 94.52.142.198




  • here is also the dashboard



Log in to reply