Transparent proxy is forcing on OpenVPN (solved)



  • Hi,
    I was wondering if someone could help me out what i missed?

    So at my home i am running pfSense (192.168.3.254) with WPAD and transparent proxy so far its running good until today i wanted to connect though OpenVPN to another pfSense (192.168.10.251) and I can ping it but i cannot access the webpage as also I have a gadget that shows when im in a proxy. So then i tired though L2TP and as you can see the photos the IP changes to the external and works. I disabled transparent and works but im not sure what I would need to change on the config of squid for it to let me ignore the transparent proxy.

    Thank you

    See pictures

    EDIT: so it seems it was not transparent proxy  its more of the WPAD. If I have enabled to auto detect proxy on internet explorer, chrome,firefox and i connect to OpenVPN I can ping to the devices but I cannot access though http or https because it is using the Auto detect proxy on the navigators as if I change to use system settings it works BUT I guess the real question is howcome lets say using l2tp or PPTP it completely ignores the auto detect proxy settings on the navigators and works flawless?

    EDIT: i just gave up and added a !ignore on the rules for my computer to ignore the WPAD not the best solution but its a workaround








Log in to reply