SquidGaurd Error Page + Transparent Proxy



  • Hi all,
    I'm using a transparent Squid proxy.

    I have just enabled SquidGuard to block porn and stuff so the kids cant get at it.
    But the error page that comes up is

    
    400 Bad Request
    
    The plain HTTP request was sent to HTTPS port
    nginx
    
    

    How do i change this or redirect it to another external website, with maybe just a DENIED image that I host on a website?

    I've tried messing with the Redirect ModeĀ  With the below options but get the same error as above each time, can someone please point me in the correct direction?

    Options:
    ext url err page
    ext url redirect
    ext url as 'move'
    ext url as 'found'.




  • Same here on some squidguard blocked content:




  • This problem solved for me when I removed the redirect url field from PackageProxy Server: Antivirus / Antivirus.
    When I tryed to fill it back in to check if it was directly connected, wasnt able to replicate the behavior. So maybe it's a bug?



  • Over a year later, I, too, am getting the same error but haven't found a solution yet.
    Antivirus is disabled so I don't know what else to try.


Log in to reply