[solved] New setup not receiving an IPv6 address on WAN Interface (Zen Internet)



  • I'm new to pfSense (first installed just after 2.3) and I have most things working fine but as yet I haven't been able to get it to obtain the IPv6 address allocated by my ISP (Zen Internet, UK).  The only address that comes up on the WAN side is an ff80… which I know is only local.

    Setup: N3150 based mini-pc, dual realtek nics (not ideal, but it's what I've got.)  The WAN connection is PPPoE via a BT supplied Huawei box.
    The box is an N3150 quad core box with dual realtek nics and replaces a flaky OpenWRT based soho router which was able to get IP6 addresses.

    Tests so far:-

    • setting the WAN configuration options to both DHCP6 and SLAAC - from what I understand either should work (correct me if that's wrong.)
    • request IPv6 prefix through IPv4 didn't fix.
    • started DHCP6 client in debug mode.  Didn't seem to tell me anything, I can't actually find anything related to IPv6 in the DHCP logs, PPP reports some IPV6CP events but doesn't list any addresses.

    I did a search but everything I found on this was from people who had their WAN addresses and couldn't get clients sorted.  I suspect that as a newbie I've stuffed something up but I can't work out what, so some pointers would be appreciated.



  • Hi motific. I'm a Zen user too. I read your post mid-week. Sorry for the delay in replying - I've just created an account so I can do so.

    First thing that's odd is that you've only got a link-local address on the WAN interface, so I agree that the first step is probably getting that sorted.

    For the record, the following settings work for me with 2.3.1. It's a basic configuration

    WAN Interface:-

    • 'IPv6 Configuration Type' is set to 'DHCP6'

    • Further down, in DHCP6 client configuration, enable "Request a IPv6 prefix/information through the IPv4 connectivity link"

    • Set the 'DHCPv6 Prefix Delegation size' to 48

    LAN Interface:-

    • Set the 'IPv6 configuration type' to 'track interface'

    • Further down, in 'Track IPv6 Interface', set the 'IPv6 Interface' to your WAN interface

    • Specify an IPv6 prefix ID as instructed

    It's been six months since I set mine up, but if I recall correctly, you need to specify the prefix delegation size explicitly.

    I hope that's of some help. I'd also urge you (if you haven't done so) to get in touch with Zen support. In my experience, they're very approachable and you can get to speak to someone technical fairly easily.

    I'm happy to post some redacted logs or other info if that will help.

    Best of luck



  • Thanks - that nailed it.

    Looks like though I'd tried the /48 and IP4, I clearly hadn't done both at the same time.


Log in to reply