No 64bit Counters Available in 2.3.1_p5 / UI bug



  • Running the latest stable pfsense 2.3.1-RELEASE-p5 (amd64), SNMP does not return any HC/64bit counters, meaning they roll over and I can't monitor my interfaces above 120mbps or so.

    Searching around shows a few other users reporting this problem but without any response, I know pfsense returned 64bit counter previously, pretty sure in 2.3

    Also this may be a UI bug, but should I be able to uncheck the mibII module in the UI? When I uncheck it, it restarts the daemon as it should, but then if I go back to the SNMP page, all the modules are checked - http://i.imgur.com/2PuNutQ.png

    Tried on a brand new fresh install of pfsense just in case, still no HC counters. Do you enable 64bit SNMP counters based on detected port speed? it's running in a VM so it doesn't see a set link/media speed, just says media: manual. Everything else works 100% though



  • herro



  • Are you running Hyper-V? My Hyper-V VM's don't have 64-bit counters, but my physical boxes do. I figure this has more to do with Microsoft and them trying to move away from SNMP.



  • nope, xen. Past pfsense versions I've ran in the exact same config had working 64 bit counters but a recent change in 2.3 made them go away. Plenty of other OS's running in VM's here have working 64 bit counters so I'm not sure how it would be a hypervisor issue