Trying to setup the opt interface



  • Hello i am trying to set up my opt interface to use with my Dir-655 D-Link router witch I have turned into a Access point and i want to use it on the opt interface with the ip of 192.168.4.1.  So I have tried three different peoples deals and I contacted a business that dose work with pfsense but he wanted to charge me to get it up and running.  So here is all i want to do is get the internet through to the AP it is hooked up on the opt interface and is set to 192.168.4.1 then the ap is 192.168.4.2 and I went in and did the dhcp server firewall rules and all that one person said to do.

    It still will not talk to the internet when I get on a wireless device it just pops up with server not found. I am running pfsense ver 2.3.2 and the Dir-655 is hooked to the lan port on the back of it and is plugged into the opt port witch I set to 192 .168.4.1 and the ap is set to 192.168.4.2 and all the stuff i followed to do the pfsense router settings . any help would be appreciated thank you for your time.

    All my lan ports works just great and the wan is working fine to just the opt port is not going out to the internet. on wireless devices.

    I have a lan set up with a different ip address but it is working just fine like I said it is the opt the isn’t working.


  • Netgate

    Post this:

    Interfaces > OPT1
    Firewall > Rules, OPT1
    Firewall > NAT, Outbound

    If you connect a computer to OPT1 does it get DHCP in the 192.168.4.0/24 network and is it able to access the internet?



  • Thank you for your help.  it still don’t work I forgot to do the nat thing so I went in and did that but it still don’t work my laptop gets a IP from the opt interfaces but no internet connection can be made so I don't know what I am doing wrong.  I am kind of stupid on this kind of stuff but I do the best I can. Thank you again no one wants to help me on things unless they are getting paid and I don’t make that kind of money I am just a poor man doing with what I have.  But I help any one I can with what I have and never do I ask for anything in return so thank you for whet you have done so far.

    Ron Frazier AKA Wildmanron


  • Netgate

    So post the information asked for. Not possible to see what you have done wrong without being able to see it.



  • So what would be the best thing for you to see it I have team viewer on all my work stations I could set one up so you could check it out if that would work for you.


  • Netgate

    Screen shots of the requested pages. Post them as attachments as a reply here.



  • Ok here is all the screen shots of all the settings in all the places you requested some of them are two shoots per each one of the setting areas.

    ![Screenshot from 2016-11-23 12:37:40.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:37:40.png)
    ![Screenshot from 2016-11-23 12:37:40.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:37:40.png_thumb)
    ![Screenshot from 2016-11-23 12:38:03.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:38:03.png)
    ![Screenshot from 2016-11-23 12:38:03.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:38:03.png_thumb)
    ![Screenshot from 2016-11-23 12:38:37.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:38:37.png)
    ![Screenshot from 2016-11-23 12:38:37.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:38:37.png_thumb)
    ![Screenshot from 2016-11-23 12:38:51.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:38:51.png)
    ![Screenshot from 2016-11-23 12:38:51.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:38:51.png_thumb)
    ![Screenshot from 2016-11-23 12:39:12.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:39:12.png)
    ![Screenshot from 2016-11-23 12:39:12.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:39:12.png_thumb)
    ![Screenshot from 2016-11-23 12:39:28.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:39:28.png)
    ![Screenshot from 2016-11-23 12:39:28.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:39:28.png_thumb)
    ![Screenshot from 2016-11-23 12:40:01.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:01.png)
    ![Screenshot from 2016-11-23 12:40:01.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:01.png_thumb)
    ![Screenshot from 2016-11-23 12:40:14.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:14.png)
    ![Screenshot from 2016-11-23 12:40:14.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:14.png_thumb)
    ![Screenshot from 2016-11-23 12:40:24.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:24.png)
    ![Screenshot from 2016-11-23 12:40:24.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:24.png_thumb)
    ![Screenshot from 2016-11-23 12:40:36.png](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:36.png)
    ![Screenshot from 2016-11-23 12:40:36.png_thumb](/public/imported_attachments/1/Screenshot from 2016-11-23 12:40:36.png_thumb)



  • Just a quick note to let you know i just hooked up my net book to the same opt interface i put a little 5 port switch on the opt port and i have all my laptops plugged in and they all have ip address and all that but no internet connection yet.


  • Netgate

    Your rule on OPT1 is TCP-only. Change that to protocol any



  • I want to thank you so much it has come to life but I am being told on my laptops that when I am trying to go to a web site it tells me that the site isn’t secure. like google it says your connection is not secure and gives you the option to go back and advanced never seen that happen before on Google or Youtube even dose the same thing. it dose the same thing when i log into my Thunderbird on my Ubuntu laptop it brings up a add security exception box is this normal or do i have a security problem with the opt interface.


  • Netgate

    Did you do something silly like try to enable squid?

    Again, screenshots of the error - especially the certificate details.



  • Also my wireless phones work just fine it seems I can get my mail and surf the web on them but the laptops keep telling me there is some kind of security deal going on.


  • Netgate

    Nothing in pfSense gets in the middle there unless you put it there.



  • this is weird i just tried to go to the google web sit and youtube and different things like that and now they go right through no problems. I can seen the one pic of google deal but now it goes right to google



  • here is the pic of the security deal




  • I really want to thank you for all the help on this matter today you took the time out of your day to help and I will never forget that you are a good friend to have.  Most of these forums don’t even have the guts to help someone they just act like you never posted to them.  I have some posts into the Ubuntu site that have never been answered so I want you to know you are number one in my book.

    Thank you so much have a great Thanksgiving and and a great Holiday Season.
    Ron Frazier AKA Wildmanron


  • Netgate

    I do not know what is getting in the middle there.

    Click Advanced there, then Add Exception, then View, then post a screen show of that certificate information, then Close and Cancel.



  • The security deal disappeared all the laptops go right to the web sites now with no problem youtube and google are working just fine I didnt do anything with the buttons on that security thing and i went to get a screen shot of the youtube one and it just disappeared and everything works fine now.


  • Netgate

    OK good to hear.

    As long as you didn't click and create certificate exceptions for those you should be OK.



  • no I didn’t touch the buttons on any of the deals. thank you so much now I have internet through my wireless side that is what I need so I can hook up a couple more Access Points thank you so very much for your hard work and time. and thank you for the fast response to all my questions at least you care about helping to get others up and running. A lot of these sites take for ever or never answer at all. I will always put a good word in for you

    your Friend Ron Frazier AKA Wildmanron