Embedded full install => with cf ok with microdrive fails



  • hi !

    i made a full install for my alix2c3 on a cf media (i know but it was only for 3 days to test) following this http://devwiki.pfsense.org/FullInstallOnWRAP guide and it worked (except when this is executed 
    rm -rf /mnt/boot / cpdup /tmp/mnt/boot /mnt/boot  i always get failure that /boot/loader.rc can't be deleted or overwritten)
    but anyway install on cf card worked for a few days. Yesterday i received finally my microdrive and did exact same steps but after kernel boot  its unable to mount root ad0s1a .
    I also changed media handling in alix bios (CHS LBA etc.) but i never saw during kernel boot that there is a hd/cf recongnized
    So where now i my mistake….

    ciao gerd



  • Gerd what brand of microdrive do you have?
    I tried a seagate 4gb for embedded applications (bought it cheap on ebay. think it was an ipod pull) and it did not work for me. I had exactly the problem you described using pfsense 1.2 (bsd 6.3). Kernel would boot but could not mount partition.
    I then tried an hitachi 4gb and it worked flawlessly. I hear that seagate for embedded applications does not implement IDE correctly and in fact it does not work on many digital cameras as well.

    Johnny



  • @http://forum.pfsense.org/index.php/topic:

    cheesyboofs posted some info on how to get certain types of microdrives to run.
    http://forum.pfsense.org/index.php/topic,11016.msg61193.html#msg61193



  • i followed the tutorial but still no success
    (snapshot from yesterday)
    point is during install doing rm -rf /mnt/boot programm complains after  that directory is not empty
    and during cpdup /tmp/mnt/embedded/boot it complains about thta command is not able to replace loader.rc (i also checked loader.conf and hw.ata.ata_dma=0 is inside)
    during bootup i can't see any recogniton of the harddisk (microdrive)
    the last entry when boot fails is
    sio1: port may not be enabled
    Timecounter "TSC" frequency 498053928 Hz quality 800
    Timecounters tick every 10.000 msec
    Fast IPsec: Initialized Security Association Processing.
    Trying to mount root from ufs:/dev/ad0s1a

    Manual root filesystem specification:
      <fstype>:<device>  Mount <device>using filesystem <fstype>eg. ufs:da0s1a
      ?                  List valid disk boot devices
      <empty line="">      Abort manual input

    mountroot>
    when i follow this http://forum.pfsense.org/index.php/topic,11016.msg61193.html#msg61193 giude its still the same…
    Microdrive is a seagate....

    ciao gerd</empty></fstype></device></device></fstype>



  • the mount root failure is because it's a different device than the box you used to install. Type in the correct device name at the mountroot prompt, look at the boot messages to determine what it is. It'll be something like:

    ufs:da0s1a


Log in to reply