Can't Install on Soekris net5501 W/ CF



  • I am running Linux on my workstation, so I've downloaded pfSense-1.2-Embedded.img.gz.  When I plug in my CF card, it comes up at /dev/sde so I use this command to copy to my CF:

    zcat pfSense-1.2-Embedded.img.gz | dd of=/dev/sde bs=16k

    The CF is 2GB, which was the easiest thing for me to get locally, if the extra size makes a difference.  When I pull the CF out and put it back in my card reader, Linux tries to read it and sees it as using UFS, but always reports that it can't read /dev/sde4.  It doesn't reference any other partitions, only /dev/sde4.  I've been told this shouldn't be an issue, that I just don't have the right libs installed to read UFS.  So I took the CF card and put it in my net5501 and connected the power.  I get this:

    Intel UNDI, PXE-2.0 (build 082)
    Copyright (C) 1997,1998,1999  Intel Corporation
    VIA Rhine III Management Adapter v2.43 (2005/12/15)
    PXE-E61: Media test failure, check cable

    PXE-M0F: Exiting Intel PXE ROM.

    No Boot device available, enter monitor.

    I'm new to pfSense and Soekris.  I've searched on this forum and with Google, and in all cases, I see info on copying to the CF and on options to pick, but the steps from powering on to accessing pfSense on my net5501 through the serial port are all skipped, so I would think that normally when the pfSense image has been copied over to CF and put in the Soekris box, that it should come up immediately on boot without extra steps.

    That's not happening.  I've tried stepping through all the boot devices listed with the "show" command, but nothing works.

    I'm following directions that I've seen in several places that all jive with each other.  What am I doing wrong and what do I need to do to get the net5501 to boot pfSense when its powered up?

    Thanks for any help/insight on this!



  • I didn't mention in the first post that I was puzzled because the line about media failure said to check the cable, so I figured that was off.

    It turns out it's on target.  I tried 2 different Transcend 2GB CF cards and got the same problem with both.  The cards said they did 266x speed.  Today I got a SanDisk 2GB CF card and it's working just fine now.

    So problem solved and I just won't count on Transcend for my RAM cards anymore.



  • I am aware that this issue is fixed. I just thought I would throw this in for anyone who was interested later.

    We have many different compact flash cards and have not had a huge amount of problems using them. From what I could gather our issue with some cards was that they are a tiny bit different in size than standard and therefore they were not big or small enough for our images. We use a standard 256 MB image of our own creation so we don't need to use serial ports (its preconfigured). Trancend is one we have used before so maybe it was a different issue with the newer cards.



  • @HalNineThousand:

    I didn't mention in the first post that I was puzzled because the line about media failure said to check the cable, so I figured that was off.

    That error refers to the onboard network interface not detecting a link (the hint was in the reference to PXE).


Log in to reply