Redis needs manual start from shell, to get NTOPNG working



  • Hello

    i've installed Ntopng package.

    It was not working until i start manually in the shell the "redis-server"

    it's probably due to the message during ntopng installation

    _Message from redis-3.2.6:
    ===>  CONFIGURATION NOTE:

    To setup "redis" you need to edit the configuration file:
          /usr/local/etc/redis.conf

    To run redis from startup, add redis_enable="YES"
          in your /etc/rc.conf.

    Cleaning up cache… done._

    What do i do to get redis probably automatic start ? ive not modified rc.conv because there's a message inside telling not to modify the file

    Thanks in advance


  • Banned

    No it does need any such thing. Simply configure the package via the GUI and save configuration.



  • Thank you for the answer

    Unfortunateky i've not seen any option in the config pane to solve this

    I saw other people having the same issue

    I do not know on this freeBSD distrib how to make this command run on startup to fix this

    Does anyone have a clue of that ?

    Thanks :)


  • Banned

    That message is completely irrelevant on pfSense. Redis is already started via /usr/local/etc/rc.d/ntopng.sh script created by the package. If it doesn't start for you, you have a different problem.



  • In case this helps someone else...

    Redis was also failing to start automatically on my install. It turned out that the /var/db/ntopng/ntopng.rdb file was null, which was causing the Redis start command in /usr/local/etc/rc.d/ntopng.sh to fail.

    To fix it, I uninstalled NTOPNG via the GUI and deleted the /var/db/ntopng/ folder:
    cd /var/db/ntopng/
    rm -rf ntopng/

    I then re-installed via te GUI and it's fixed.

    (I'm running pfSense 2.2.4 and NTOPNG 0.8.13)