Why are ping accepted, but not HTTP traffic?



  • Hello,

    My LAN is in the 192.168.1.0/24 subnet with an internet connection and a pfsense firewall. I have an other network which is 192.168.2.0/24 and has a separate internet with a pfsense too. At my pfsense which is in 192.168.1.0 I have a static route configured to network 192.168.2.0.

    From network 192.168.2.0 I can ping to network 192.168.1.0 fine the same the other way. However on network 192.168.2.0 I cannot access websites which are on network 192.168.1.0.

    See screenshot of the pfsense in network 192.168.1.0 firewall log of LAN interface - what puzzles me from a client on network 192.168.2.0 I can ping the machine 192.168.1.99, but http traffic is not allowed. The pfense has the standard rule for the LAN interface applied.

    Thanks,
    Edy

    ![firewall rule.jpg](/public/imported_attachments/1/firewall rule.jpg)
    ![firewall rule.jpg_thumb](/public/imported_attachments/1/firewall rule.jpg_thumb)



  • You have an asymmetric routing issue.
    It seems that the request packets from 192.168.2.0/24 doesn't pass the firewall of 192.168.1.0/24, while responses try to pass, but are blocked, since pfSense is missing the SYN packet.

    @Fafa24:

    what puzzles me from a client on network 192.168.2.0 I can ping the machine 192.168.1.99, but http traffic is not allowed.

    The ICMP protocol is stateless, so response packet can pass, no matter if the request packet took the same way or another one.
    TCP is a stateful protocol.



  • Okay - thanks  I found the relevant docs for pfsense. I guess this is the article to refer to https://doc.pfsense.org/index.php/Asymmetric_Routing_and_Firewall_Rules



  • For a TCP communication you need routes on both routers. Also on the pfSense in 192.168.2.0/24 you have to add a route pointing on the other router.



  • Thank you - I was able to resolve it

    I checked "Bypass firewall rules for traffic on the same interface"

    I have the same interface configured on both Pfsense.


  • LAYER 8 Global Moderator

    ""Bypass firewall rules for traffic on the same interface""

    That is NOT the correct way to fix asymmetrical routing… If you have 2 different routers and you want to route between them - then connect them with a transit/transfer network.

    If you have 192.168.1/24 on 1 and 192.168.2/24 on the other - connect the 2 routers with say a 172.16.0/30 transit and create the appropriate routes..



  • Thanks for your input - I really appreciate it, so I can learn how it works and what is the correct way. I unchecked the option and I had to set a default gateway on the optional interface for network 192.168.1.0. This was the problem. No gateway was set in the interface. Does this make sense?

    I can browse now from both subnet websites on the other subnet and also use UNC for file share access.


  • LAYER 8 Global Moderator

    draw your network… if you do not have a transit network I can almost promise you have asymmetrical..

    If you have this its asymmetrical!  unless you host route on each device in the 192.168.1 network.

    2nd pic is non symmetrical





Log in to reply