Embeded boot failes



  • I'm trying to install pfsense 1.2.2 on a Intel BOXD945GCLF2 Atom 330 945GC with 2gb ram and a 2gb cf card in a ide adapter.
    The imaging seems to work fine and i've done it from windows and 2 linux machines.
    When i try to boot from the cf card i get a hardlock with the following on the screen:

    
    /boot.config: -D
    BTX Loader 1.00  BTX version is 1.02
    Consoles: internal video/keyboard  serial port
    BIOS drive C: is disk0
    BIOS 572kB/2085068kB available memory
    
    FreeBSD/i386 bootstrap loader, Revision 1.1
    (sullrich@freebsd7-releng_1_2_1.pfsense.org, Thu Jan 8 22:51:03 EST 2009)
    Loading /boot/defaults/loader.conf
    /
    
    

    (the last line is a spinning cursor that stops at /)

    I have tried several different versions of pfsense including the latest alpha and all give the same problem.
    The latest version of m0n0wall works fine, as does installing to a cf card from the livecd.
    I have also tried the same cf cards on another system (nforce2 based) and the same problem occurs.
    I have disabled the onboard sata controller and set the ide controller to legacy with no changes.

    I'm not really sure what else i can try, any ideas?



  • I assume you did an embedded-install:

    @http://forum.pfsense.org/index.php/topic:

    The embedded version does not have any VGA output. Connect and configue per Serial port.



  • I found the previous reply a little cryptic and had to think about it for a while.

    If you boot the embedded version it will talk to you over the serial port, not the screen. If you have a BIOS that supports VGA then its likely the early part of the boot output will go to the screen but once the boot is sufficiently far along the output will be to the serial port. I have no experience of the embedded version so can't comment on when that transition from screen output to serial port output occurs.



  • Sorry if my reply was cryptic :D

    The transition to the console happens exactly when mrjackson described.
    At the spinning /

    The default console speed is 9600 8N1

    But tbh: If you followed any of the guides to install the embedded-version you you should have known about that.



  • Thanks everyone, that "problem" is fixed after searching for an hour for my serial cable, i feel kinda stupid for not seeing that anywhere but it does seem kinda hidden imo.

    Now a 2nd problem…

    When booting it runs through a bunch of stuff then gets to a point where it cant find the root drive to mount, hitting ? doesnt show any drives at all. I have tried disabling DMA (hit any key during boot and set hw.ata.ata_dma=0) but that doesnt work either. I have disabled the sata and set the pata to legacy with no change.



  • Your motherboard, being pretty new, probably boots from USB mass storage. If you have a CF USB adapter you could try booting from the CF in a USB adapter. You will probably still get a mount issue but the USB mass storage device may be visible (dax rather than adx for ATA drives).

    If you have a USB stick you could try putting the image on that and booting from that - likely same mount issue.

    In my office we use a variety of CF cards as boot devices. The older ones tend to be more quirky than the newer ones, but 2GB is pretty new. I have a Seagate 4GB micro drive I was never able to get working in a CF-IDE adapter but it seemes to work pretty well in a CF USB adapter. (An example of USB adapter hiding some quirks.)

    I have booted pfSense from a SD card in a SD USB adapter. Though be aware that USB memory card adapters have their quirks too and not all them work reliably with FreeBSD. Something different, some more data points.

    Does your CF card show up at all in the boot? On my system (has Flash disk module, not CF card):

    ad0: 955MB <transcend 20071207="">at ata0-master UDMA33
    WARNING: Expected rawoffset 0, found 63
    Trying to mount root from ufs:/dev/ad0s1a
    #</transcend>

    In your startup output (CF in IDE adapter) do you get similar lines?



  • boot number 3 - Safe mode, you will have to be quick when pressing 3 in the menu.
    then edit /boot/loader.conf and add

    hw.ata.ata_dma="0"
    hw.ata.atapi_dma="0"

    this will take care of the DMA and your system will start fine with the default boot.


Locked