Trouble installing 2.4.3 on an SG-2440