Dashboard issue on nanobsd



  • I have installed the nanobsd on a 2GB CF and it worked fine. I'm using theses images:

    • pfSense-1.2.3-2g-20090723-0533-nanobsd.img.gz
    • pfSense-1.2.3-2g-20090723-0533-nanobsd-upgrade.img.gz

    The only problem is that after Dashboard v0.8.3_1 installation the System -> Packages and Diagnostics -> NanoBSD disappeared. Only to check if it was related with package installation process, I installed the images again and tried to push another packages (Backup, Cron, blinked) and it works perfectly. So I concludes that the issue is related with the Dashboard.
    There is another post relating this problem: http://forum.pfsense.org/index.php/topic,18009.0.html

    After checking some files I found that /usr/local/www/fbegin.inc is the one that generate the menu. It's strange because the Dashboard installation file /usr/local/pkg/dashboard.inc don't touch on the fbegin.inc. I don't know the whole installation process to go deeper, so I fixed the fbegin.inc manually.
    These are the parts modified to get the Packages and NanoBSD showed again:
    After line 124:```

    
    And after line 243:```
    *   [Routes](/diag_routes.php)
    ```put:
    
    
    I guess we need a fix for this… tks!

  • Rebel Alliance Developer Netgate

    The dashboard package does overwrite fbegin.inc.

    I'll can add some code to handle this, but it might be a few days before I have an opportunity to get it done.



  • I see, the overwrite is done by the widgets.tgz. Enclosed is the patched file with the correct fbegin.inc. Pls rename it to .tgz

    widgets.jpg


  • Rebel Alliance Developer Netgate

    I committed a fix for this in Dashboard 0.8.4, which should now be on the package servers.


Log in to reply