Need Help! I don't know how to setup internet connection at my PFsense router



  • Hi everyone!

    I've just set up my pfsense router. I connected an cable to my LAN network(eth0)  and the other to WAN (SpeedTouch router)(eth1).
    I have finished setup wizard, but I can't get internet connection at my LAN network. When I ping google at the PFsense firewall itself it works. Do I have to open ports on network or something. Please help me!

    Thanks  ;D



  • remove the router and leave pf-you are performing double nat which can cause problems. since its a dsl "router" put it in bridge mode. (dsl routers are technically gateways as they combine the modem and router functions into one device). some dsl modems dont require this (Qwest) others do. either way you have to have the modem in bridge mode to get the full benefit of pf. the go to interfaces -> wan then general config and change to ppoe or ppoa whatever your isp uses. (mine used both and modem was set to ppoa but when i did ppoa with pf not all sites worked had to change to ppoe which qwest says is for when a modem is in bridged mode)  go to ppoe/a config enter your credentials and edit the settings you want.



  • I am having the same problem, except I don't have the router in between, it's just a modem. PFsense can ping any website, so I know the internet is working and any computer on the local network can get to the PFsense web configurator so I know the local netowrk is fine. It just won't route traffic through. I have the DNS Forwarder set up, but DNS lookups on computers on the network get some 216.x.x.x address for every lookup, so I don't unterstand what's going on.

    I am running it with VMware Workstation on Windows Server 2008. Thanks for the help!



  • try changing from ppoa to ppoe

    if you have console access type in option 100 (the links web browser) and try to access google.com, you will have to hit esc first and then f1 and then select go to and type in http://www.google.com if you can access it that way then it is either the ppoa/ppoe setting (switch to the other that you are not using) or the disk is full on pfsense, search the forums for clearing the squid cache.

    try doing 1:1 nat


Log in to reply