Inetd[568]: 19486/tcp: bind: Address already in use



  • Running 1.2.3-release.  I'm getting this message in my system logs for a few of the ports used for nat bouncing according to /etc/services.  Seeing it for 19487 and 19488 as well.  What would be causing this?


  • Rebel Alliance Developer Netgate

    Do you have overlapping port ranges in a port forward? Or perhaps an alias of ports in use on a NAT rule?

    Maybe using the same port on two different VIPs with reflection enabled (Though I thought that was handled in the code, but I haven't looked)

    Reflection was completely overhauled on 2.0, you might give it a try and see if it behaves any differently with your configuration.



  • Could it be because I've got port forwards and a 1:1 NAT defined for the same VIP?  I changed to 1:1 for one of my mail servers and didn't remove the port forwards at the time I changed that over.


  • Rebel Alliance Developer Netgate

    NAT Reflection doesn't work for 1:1 NAT in 1.2.3, so probably not. It wouldn't hurt to remove those port forwards as a test though.



  • Nope, that didn't make a difference.  Still getting the message every 10 minutes.  I will keep digging, doesn't seem to be hurting anything



  • Do you have any services listening on those ports on that system?



  • inetd should not be running on pfSense at all AFAIK.



  • If NAT reflection is enabled then it does run inetd (there may be something it runs it for even if reflection is disabled).  19000-19999 is the range of ports that can be put in the inetd configuration by NAT reflection.  If something else is already listening on one or more of those ports, that would be why the message is coming up in the logs.  The number of ports used by inetd in pfSense 1.2.3 is approximately equal to the number of ports forwarded * number of non-WAN interfaces configured.  In 2.0, this is reduced to simply the number of ports forwarded.



  • Oh yeah, good call.  I think inetd spawns a bunch of netcat listeners to facilitate NAT reflection.  My bad, totally forgot about that.



  • @Efonne:

    Do you have any services listening on those ports on that system?

    Nothing listening on those ports, and now the logs are ports 1926x so I'm not real sure what is happening here.  I don't use reflection since I have internal DNS setup so I'll just disable it for now and at least verify that is definitely the problem.



  • I'm not really familiar with all of the bugs that might be in reflection on that version.  There could even be some duplicate port numbers in the configuration for inetd.


Log in to reply