PfSense Quick/Advanced Install – TIMEOUT - WRITE_MUL retrying (1 retry left) ..



  • 1. One of these puppies with all thermal pastes changed to Arctic Ceramique (server is running very cool and normal; did do a burn-in)

    2. Brand new Western Digital 160GB IDE Blue HDD

    3. pfSense 1.2.3 stable on a CD

    Whether I do quick install to HDD or advanced, it will always stop at this part in the setup process:

    /usr/local/bin/cdup -vvv -I -o /usr /mnt usr
    38%

    ad0: TIMEOUT - WRITE_MUL retrying (1 retry left) LBA=135150603

    And it seemingly does nothing. The LED for HDD activity is solid blue, and the |/-\ thing on the left side of progress bar continues to "rotate." FYI, the first thing I even did before pfSense is to run ViVard (for no reason at all) to scan for errors + remap. No errors found.



  • Can you try disabling UDMA mode in the BIOS for the drive and try again?



  • Okay, well I had left it to run over the weekend, not expecting anything to change, but when I arrived this morning and took a look, it managed to install pfSense and had brought me to a screen asking me to chose whether it should be uniprocessor mode or use both processors (I selected both processors). Got through this, removed the CD, rebooted.

    Now, during the boot up process it gets to a screen like this:

    F1 FreeBSD

    Boot:

    Either I can wait or just F1, either way will be the same result. On the next line on the screen, it will show a ** with a blinking cursor underneath it. It just sits there the whole time like this. I thought that maybe it has already booted and is doing this so as to be transparent/silent (not show console output or anything), and that I am supposed to connect my laptop to the LAN port and access the WebGUI to configure it.

    Unfortunately, when I do that, it will end up only pulling out a 169.154.x.x IP for my laptop. :( What have I done wrong?

    EDIT: In BIOS, these are the only options for DMA on the HDD (currently set to Auto, which I think is using UDMA6):

    Auto
    SWDMA0
    SWDMA1
    SWDMA2
    MWDMA0
    MWDMA1
    MWDMA2
    UDMA0
    UDMA1
    UDMA2
    UDMA3
    UDMA4
    UDMA5
    UDMA6

    EDIT2: I am redoing my diagnostics on the HDD just to absolutely confirm its cleanliness.

    ViVard 0.4 scan with remap – pass, no errors
    GSmartControl SMART Short Self-test – pass, no errors
    GSmartControl SMART Extended Self-test – pass, no errors
    GSmartControl SMART Conveyance Self-test – pass, no errors
    TestDisk – Bad sector count (?? :o )



  • Your drive might be faulty.  To confirm this, go to Western digital's website and download a bootable CD ISO called Data LifeGuard.  Boot this CD on the system and use the utility to run a test on the drive.

    If the drive is faulty, take down the diagnostic error report message and include this with your RMA service request.  This will expedite the RMA process since WD does not need to ask you to run this test, nor do they need to run this test internally to check if the drive is really faulty.  You simply ship the drive to them and they send a new replacement to you.

    On the UDMA portion, this was a bit of an issue with older FreeBSD versions that some people could solve by disabling DMA in the kernel.  Since your drive seems to be having issues, this doesn't seem to be the issue at hand.

    Also, you can actually use a SATA drive with the system.  Just provide your own SATA cable.



  • Yes, we can use SATA, but unfortunately we're too cheap to buy a SATA harddisk now since we already have a harddrive. ;\ (Would also have to buy a SATA power adapter since the power supply doesn't have any SATA plugs).

    I very much appreciate your advices and help!



  • Okay, well I shipped off the drive for replacement. In the mean time, I tried an 80GB Seagate IDE that passed the ViVard test (never got to SMART tests). pfSense install goes through without any errors.

    Restart.

    Get past F1/FreeBSD part.

    pfSense boot menu pops up for a few seconds (I wait so that it uses default bootup parameters).

    It prints the following line on screen followed by a second line "|" (with blinking cursor underneath) that doesn't move or do anything:

    /boot/kernel/acpi.ko text=0x527e0 data=0x2400+0x186c syms=[0x4+0x8660+0x4+0xb187]

    Nothing happens. I can press keys on the keyboard and nothing happens. If I do CTRL+ALT+DEL it instantly restarts.



  • Can you try choosing boot with ACPI disabled in the menu?



  • Yeah, I tried that and Safe Mode. Neither worked; only difference was that it didn't show that line and just shown the | or \ thing.



  • Try disabling any form of RAID in the BIOS.
    Under IDE configuration, set Enhanced mode to 'Off' and Legacy mode to 'PATA only'.

    Also, disable HyperThreading and unused onboard devices (spare com ports or parallel ports etc).

    If possible, try updating the BIOS (download from Tyan's website).



  • Try disabling any form of RAID in the BIOS.

    Already disabled (by default).

    Under IDE configuration, set Enhanced mode to 'Off' and Legacy mode to 'PATA only'.

    No dice.

    Also, disable HyperThreading

    No dice.

    and unused onboard devices (spare com ports or parallel ports etc).

    Unused onboard devices are already disabled (by me).

    If possible, try updating the BIOS (download from Tyan's website).

    No dice.

    I will try the two or three other options at the end of the installation for the kernel and see if any of those will work.

    Multi-processor – (as we know it) doesn't work
    Uni-processor -- doesn't work
    Embedded kernel -- doesn't appear to work

    Embedded kernel gets stuck in the same screen containing "F1 FreeBSD" at the very top.. but the last two lines are:

    Loading /boot/defaults/loader.conf

    With a blinking cursor on -.

    I can't mount the HDD through PartedMagic either. I use mount -t ufs -o ro,ufstype=ufs2 /dev/sda1 /mnt/hdd (after having mkdir'd hdd in mnt). The partition editor also says that its of an unknown filesystem.



  • Am I out of luck? :( LiveCD works fine…





  • @sullrich:

    Take a look here http://doc.pfsense.org/index.php/Boot_Troubleshooting

    I tried a bunch of things there, including a few things on http://wiki.freebsd.org/BugBusting/Commonly_reported_issues, and it doesn't solve my problem. However, I noticed this gibberish text that is included in the reboot sequence immediately following installation: http://www.hlrse.net/Qwerty/pfsense_IMG_2299.jpg

    You can find the video at http://www.youtube.com/watch?v=ydKzAS2Or1c

    When I try to fsck using FreeBSD LiveCD v4.6:

    [LiveCD] /dev # fsck -f ad0a
    ad0: rejecting BSD label: raw partition offset != slice offset
    ad0: start 63, end 156301487, size 156301425
    ad0c: start 0, end 156301424, size 156301425
    ad0: cannot find label (fixlabel: raw partition offset != slice offset)
    ad0s1: rejecting BSD label: raw partition offset != slice offset
    ad0s1: start 63, end 156301487, size 156301425
    ad0s1c: start 0, end 156301424, size 156301425
    ad0s1: cannot find label (fixlabel: raw partition offset != slice offset)
    Can't open ad0a: Invalid argument
    [LiveCD] /dev #



  • I received the replacement WD drive today, and I handled it as carefully as I could possibly handle a harddrive. I even made sure to completely electric tape the metal cage it mounts into in the server. Then I proceeded to Advanced/Expert install it, and selected "Linux" instead of "FreeBSD" in the partitioning part; I next/OK'd my way through the rest, and I do not recall any errors popping up. :)

    Installed with symmetric multiprocessing. All find and dandy. I reboot, wait, see the "Boot: F1" little menu (however, it shows "F1 FreeBSD" in the list instead of Linux as I was hoping), wait, loads up pfSense menu (yay!), I wait (not anticipating progress past the first line), but indeed it continues to load. Sweet.

    I come back a couple minutes later (because I got distracted), and I find myself at this:

    D:

    What do I do? Arr!

    And so I try the other options from the pfSense menu.

    ACPI Disabled

    Safe Mode

    Single-user

    Escape boot loader

    EDIT: Have to reinstall pfSense because GAG borked pfSense' boot.
    EDIT2: Now, after reinstalling, it doesn't even get passed the "Boot: F1" screen. It just hangs at "".
    EDIT3: OK well now I can't get past the "Boot: F1" screen period. :( I tried Easy install and it still does it.
    EDIT4: I pop in LiveCD, escape loader to get to GO prompt, type lsdev to find out I need to try boot disk0s1a, and so I type boot /dev/disk0s1a and for a split second it spins but then stops on "" in the rotation and does nothing (the cursor thing underneath it is still blinking though).
    EDIT5: Currently doing a full format with PC DiskEraser from PartedMagic. Also burning a brand new copy of pfSense.
    EDIT6: Nope. Going to try w/o Packet mode.



  • Sigh, this is dumb. :( I give up for now. I can't get past the Boot:F1 screen any more.

    EDIT: Guys, I'm going to put Winblows on this box if I don't get help. ;D
    EDIT2: I kid – sorry, poor joke. :( I'm just really frustrated and need to get this done and any time I have ever dealt with Linux it's just one frustration after the next. By no means do I hate Linux; both Windows and Linux have their pros and cons, functions and purposes. I am honestly and sincerely wanting to learn Linux and environments and such.



  • Get a spare SATA drive and try.  The IDE controller might be shot.  In fact, you probably have some hardware issues w.r.t. the chipset.



  • pfSense is based on FreeBSD not Linux.

    Its a long time since I've done a full install. I mostly do a firmware upgrade to change versions. However I did a full install of pfSense 2.0 BETA 4 last night on a Virtual Machine under Virtual Box and it proceeded without problem.

    I can't recall the details but I have recollections that the initial install was a bit finiky on at least one of the 9 year old machines I tried a pfSense installation on a couple of years ago. I think I had real problems when I specified GRUB as the boot loader and may have had problems when the BIOS set the hard drive to CHS mode rather than LBA. (This might be important in the early stages of a boot when the boot loader is using the BIOS to read off the hard drive rather than the boot loader using its own code.)

    I've seen the mountroot prompt come up when I've copied (physical copy) a hard drive to another and the booted from the copy. The file /etc/fstab specifies where the root file system should be found but if drives are moved (or copied) then /etc/fstab on the boot drive might not reflect the new location of the root file system. I've also seen the mountroot prompt when a drive is in a poor state.

    When my system boots it reports the location from which its trying to mount the root file system, e.g.

    ad0: DMA limited to UDMA33, device found non-ATA66 cable
    ad0: FAILURE - SET_MULTI status=51 <ready,dsc,error>error=4 <aborted>ad0: 955MB <transcend 20071207="">at ata0-master UDMA33
    WARNING: Expected rawoffset 0, found 63
    Trying to mount root from ufs:/dev/ad0s1a</transcend></aborted></ready,dsc,error>

    If you see the mountroot prompt again it would appear the proper response would be ufs:ad0s1a.

    Did you deliberately initialise a GEOM disk? If so, why? (If I recall correctly, people have reported problems with GEOM disks.)



  • Problem solved! FreeBSD didn't like large capacities for .

    Source: http://hardforum.com/showpost.php?p=1036454153&postcount=10

    @YeOldeStonecat:

    Using the IDE only….check
    Burning at slowest....check

    Hmmm....can you go into the BIOS and disable the onboard SATA ports?  Just to ensure that they're out of the way?

    They are disabled. :p

    Everything below are BIOS defaults unless otherwise stated.

    • Advanced

      • CPU Configuration

        • Ratio CMOS Settings: 255

        • HyperThreading: Enabled

      • IDE Configuration

        • IDE Legacy COnfiguration: P-ATA Only

        • S-ATA Running Enhanced Mode: No (default is Yes)

        • P-ATA Channel Selection: Both

        • Only if S-ATA Running Enhanced Mode is not No – S-ATA Ports Definition: P0-3rd./P1-4th.

        • Only if S-ATA Running Enhanced Mode is not No – Configure S-ATA as RAID: No

        • Channel 0 Master: Hard Disk

          • Type: Auto

          • LBA/Large Mode: Auto

          • Block (Multi-Sector Transfer): Auto

          • PIO Mode: Auto

          • DMA Mode: Auto

          • S.M.A.R.T.: Auto

          • 32Bit Data Transfer: Disabled

        • Channel 1 Slave: ATAPI CDROM

          • Type: Auto

          • PIO Mode: Auto

          • DMA Mode: Auto

        • Hard Disk Write Protect: Disabled

        • IDE Detect Time Out (sec): 15 (default is 35)

        • ATA(PI) 80Pin Cable Detection: Host & Device

      • Floppy Configuration

        • Floppy A: Disabled (default is 1.44 MB 31/2")

        • Floppy B: Disabled

      • SuperIO Configuration

        • OnBoard Floppy Controller: Disabled (default is Enabled)

        • Serial Port1 Address: Disabled (default is 3F8/IRQ4)

        • Serial Port2 Address: Disabled (default is 2F8/IRQ3)

        • Only if Serial Port2 Address is not Disabled – Serial Port2 Mode: Normal

        • Parallel Port Address: Disabled (default is)

      • ACPI Configuration

        • ACPI Aware O/S: Yes

        • Advanced ACPI Configuration

          • ACPI 2.0 Features: Yes (default is No)

          • ACPI APIC support: Enabled

          • AMI OEMB table: Enabled

          • Headless mode: Disabled

        • WOL S4&S5 Support: Enabled

        • Power Button Instant Off: Disabled (default is Enabled)

        • After Power Failure: Always Off

      • Event Log Configuration

      • Remote Access Configuration

        • Remote Access: Disabled (default is SMDC)
      • USB Configuration

        • USB Function: Disabled (default is 4 USB Ports)

        • Only if USB Function is not Disabled – Legacy USB Support: Enabled

        • Only if USB Function is not Disabled – USB 2.0 Controller: Enabled

        • Only if USB 2.0 Controller is not Disabled – USB 2.0 Controller Mode: HiSpeed

        • USB Mass Storage Device Configuration

          • USB Mass Storage Reset Delay: 20 sec
      • OnBoard Devices Configuration

        • Onboard ATI Video: Enabled

        • Onbaord 82551 LAN: Enabled

        • Remote Boot OS by 82551: Disabled

        • Onboard 82546 DualPort LAN: Enabled

        • Remote Boot OS by 82546: Disabled

      • Hardware Monitor

        • Auto-Control Fan's Speed: Disabled

        • Chassis Instrusion Detect: Disabled

      • Back Plan Fan Speed

    • PCIPnP

      • Plug & Play O/S: Yes

      • PCI Latency Timer: 64

      • Allocate IRQ to PCI VGA: Yes

      • Palette Snooping: Disabled

      • PCI IDE BusMaster: Enabled

      • IRQ3: Available

      • IRQ4: Available

      • IRQ5: Available

      • IRQ7: Available

      • IRQ9: Available

      • IRQ10: Available

      • IRQ11: Available

      • IRQ14: Available

      • IRQ15: Available

      • DMA Channel 0: Available

      • DMA Channel 1: Available

      • DMA Channel 3: Available

      • DMA Channel 5: Available

      • DMA Channel 6: Available

      • DMA Channel 7: Available

      • Reserved Memory Size: Disabled

      • Extended BIOS Data Area: Enabled

    • Boot

      • Boot Settings Configuration

        • Quick Boot: Enabled (default is Disabled)

        • Quiet Boot: Disabled

        • AddOn ROM Display Mode: Force BIOS

        • Bootup Num-Lock: On

        • PS/2 Mouse Support: Auto

        • Wait for 'F1' If Error: Enabled

        • Hit 'DEL' Message Display: Enabled

        • Interrupt 19 Capture: Enabled

        • Primary Display Device: Auto

      • Boot Device Priority

        • 1st Boot Device: PM-WDC WD1600AAJB-00J3A0

        • 2nd Boot Device: SS-ATAPI-CD ROM-DRIVE-56MAX

      • Hard Disk Drives

      • ATAPI CDROM Drives

    • Security

      • Boot Sector Virus Protection: Disabled
    • Chipset

      • Intel E7500/E7501 North Bridge Configuration

        • Chipset Memory Remap Feature: Enabled

        • CAS Latency: Auto

      • South Bridge Configuration

        • MPS Revision: 1.4
      • Intel PCI-64 Hub 2 Configuration

        • PCI Bus Frequency: Auto
      • Clock Gen. Spread Spectrum: Disabled

    Now, before I wrote this up and was actually preparing to write this up, I attempted to install pfSense through Advanced/Expert installation. Through this, I formatted and partitioned the harddisk, and set / to be 1024M and swap to be 8192M (this I did differently from all other installs, although I have tried partitioning the harddisk as 16GB before but without changing these values for / and swap here). This time it actually fully successfully booted into pfSense without a problem.

    I am going to try this again but partitioned to 100% (it worked like this in previous paragraph) with 16GB on / instead of 1GB, and 8GB on swap. I am also going to enable 32Bit Data Transfer on the harddrive. (EDIT: Added a third one as storage to be * (remaining capacity of primary partition).) Success.

    Trial 2: partitioned 100%, / to be 32GB, swap to be 8GB, storage to be *, BIOS settings unchanged from first trial… Success

    Trial 3: partitioned 100%, / to be 64GB, swap to be 8GB, storage to be *… Failure

    FreeBSD must have a thing about large capacities.


  • Rebel Alliance Developer Netgate

    @BlueToast:

    Problem solved! FreeBSD didn't like large capacities for .

    That isn't true of FreeBSD in general. You can have a / as large as you want in most cases. Certain BIOS implementations, however, can choke on this.


Log in to reply