No System Logs - not on webGUI not on external Syslog-Server



  • Hi,

    there is no logging information on webGUI and on external Syslog-Server on builds:
    2.0-BETA4 (i386) built on Tue Dec 14 05:32:26 EST 2010

    and

    2.0-BETA4 (i386) built on Mon Dec 13 21:32:21 EST 2010



  • I don't know about 13, but snap from 14 doesn't show here any log too.
    Looking at console shows different file-sizes, but (nearly) all logs are empty. dmsg.boot shows info, but its the only one.



  • Same for me. No log in the webUI.  :(

    2.0-BETA4 (i386)
    built on Thu Dec 16 04:59:28 EST 2010



  • Mine was broken on the Dec 14 build for i386, but it seems the logs in WebGUI are back in pfSense-Full-Update-2.0-BETA4-20101216-0237.tgz



  • Same issue for me, I upgraded and no logs at all show in the WebGUI, and also (not sure if it's related) IPsec won't work (racoon shows stopped & never starts on request–without logs hard to tell why :-)

    I wiped out my VM and added a fresh hard disk, did a new install of the pfSense-2.0-BETA4-20101216-1334.iso.gz image and restored my config backup, and still no logs, no IPsec. Then I ran the auto-upgrade to what should really be the same build (slightly apart, one for ISO build one for update): 2.0-BETA4 (i386), built on Thu Dec 16 14:34:04 EST 2010.

    Installing Open-VM-Tools attempt results in:

    Beginning package installation for Open-VM-Tools...
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading Open-VM-Tools and its dependencies... 
    Checking for package installation... 
    open-vm-tools-nox11-313025_1 
     Trying to download http://files.pfsense.org/packages/8/All/open-vm-tools-nox11-313025_1.tbz ...  (extracting)
      python26-2.6.5 
       Trying to download http://files.pfsense.org/packages/8/All/python26-2.6.5.tbz ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/i386/packages-8.1-RELEASE/Latest/python26-2.6.5.tbz.
    of open-vm-tools-nox11-313025_1 failed!
    
    Installation aborted.Removing package...
    	Starting package deletion for open-vm-tools-nox11-313025_1...done.
    Removing Open-VM-Tools components...
    Loading package instructions...
    	Include file open-vm-tools.inc could not be found for inclusion.
    	Deinstall commands... 
    	Not executing custom deinstall hook because an include is missing.
    	Removing package instructions...done.
    	Auxiliary files... done.
    	Package XML... done.
    	Configuration... done.
    Failed to install package.
    
    Installation halted.
    

    But installing the OpenVPN Client Export Utility works (manually–wasn't auto-restored from the config backup even though it said "all packages reinstalled correctdly." These were the only two packages on the system prior.

    I'm not sure how many of these are related. I can open separate threads for IPsec and package, but it all broke at once so I'm assuming there's a related issue in the latest snapshots? This VM was working perfectly until an upgrade a few days ago.


  • Rebel Alliance Developer Netgate

    There is already an open ticket about logging, though it works for me, must be something in custom syslog settings that causes the issue.

    The package bit is unrelated, though it may be resolved now. Try again, if it doesn't work, start a new thread (I think there was also a ticket open for that as well, it was just that one package)

    I haven't heard of any issues with IPsec but that would also be unrelated, and worthy of its own thread.


  • Rebel Alliance Developer Netgate



  • Package is installing fine now, thanks, and logging is working. I opened new IPsec thread.


Locked