Error after updating to 2.0 BETA5



  • I've updated with autoupdate from v1.2.3 to 2.0 BETA5.  The update went good but trouble started after booting the version 2.0 for the first time :

    I got the folowing messages :

    Migrate RRD database wan-traffic.rrd to new format
    Migrate RRD database wan-packets.rrd to new format
    Migrate RRD database lan-traffic.rrd to new format
    Migrate RRD database lan-packets.rrd to new format
    Migrate RRD database ipsec-trafic.rrd to new format
    Migrate RRD database ipsec-packets.rrd to new format
    Generating RDD graphs…done.
    Updating configuration......................................................................
    Warning: Cannot use a scalar value as an array in /etc/inc/config.lib.inc on line 406
    .
    Fatal error: Call to undefined function upgrade_000_to_001() in /etc/inc/config.lib.inc on line 405

    Anyone an idea ?

    Grtz,
    Peter


  • Rebel Alliance Developer Netgate

    What snapshot date?

    That error suggests your config did not actually load for some reason. ($config was empty or not an array like it should be)

    Anything earlier on in the console that would be either an XML error or one that mentions the config?

    We may need to see a copy of the pre-upgrade 1.2.3 config.



  • @jimp:

    We may need to see a copy of the pre-upgrade 1.2.3 config.

    I've got same issues after upgrading from 1.2.3-Release to 2.0-RC1.
    Can send you a pre-upgrade 1.2.3 config if needed.

    Regards
    flu


  • Rebel Alliance Developer Netgate

    The exact same error?

    This error:

    Fatal error: Call to undefined function upgrade_000_to_001() in /etc/inc/config.lib.inc on line 405
    

    Means that the config version tag is missing from the config.xml file, which would only happen if it were empty.

    If you want to send me the config I can have a look at it, jimp [at] pfsense {dot} org.


Log in to reply