[SOLVED] Linux Clients not registering DNS



  • I am struggling a little with a couple of Linux (Fedora Core 14) clients to get them to register their names in DNS.

    I operate DNS forwarding only allowing the pfsense to do DNS resolution on the WAN, I do not allow DNS requests from the LAN to the WAN, I do not use my ISP's DNS service.

    I have two Fedora clients that register fine with DHCP, networking is no issue and they get an IP address but the PC names do not appear in DNS and as a result pfsense tries to resolve them with opendns (the DNS service I use), when I query the machines name the result is actually some address from within opendns.

    Can somebody give me any idea what I need to do and where to make the client names register properly with pfsense when they get an IP address.

    Thanks in advance.

    PS : I have tried nsupdate ….



  • In Services -> DNS forwarder do you have a tick in the box Register DHCP leases in DNS forwarder?

    If you change that setting from "off" to "on" I don't know if DNS picks up existing leases or only new leases.



  • No it isn't that, the issue is deeper. Because those of the Linux community think that complexity and security are one and the same there is no automated mechanism to update a PC's DNS name when it obtains a DHCP address. All the Windows boxes on the network are fine, the Linux boxes are a support nightmare - and they wonder why Linux isn't catching Windows.

    You need to do all kinds of script jiggery pokery to generate keys and all manner of crap before nsupdate will function, and triggering all this when a DHCP update takes place is a pain in the hole.

    I need a simple app or script guru to point me in the right direction I can't be bothered to learn all this stuff just to achieve a simple task, I have better things to do with my time.



  • Ben, just to confirm - you've checked that the setting wallabybob pointed out is set to On?

    Having the DHCP server update a DNS domain has worked for me before, regardless of the client operating system.



  • @BenKenobe:

    No it isn't that, the issue is deeper.

    If you care to provide more details I'll help if I can.

    On my home network all the computers I expect to connect have DHCP assigned addresses keyed of their MAC addresses. On Services -> DNS Forwarder I have the box Register DHCP static mappings in DNS forwarder ticked and I don't need to do anything else to get both Windows and Linux system names in DNS forwarder.

    I don't have Register DHCP leases in DNS forwarder enabled because my sons' friends sometimes bring over their computers and plug them in and I'm trying to avoid the complications of possible name space clashes (two PCs calling themselves the same name).



  • The setting is indeed set, all the Microsoft boxes register correctly, neither of the FC14 boxes do.

    Using wireshark the FC14 based machines are NOT presenting their name as part of the DHCP request only their ID, there is no readily available option in the network manager to tell it them to submit their names to DNS whereas in most Windows boxes there is a tick box 'register this connections address in DNS' that is set by default, why the Fedora Core people can't do the same is a mystery, clearly it is too easy and not obscure enough. There used to be a file under /etc/dhcp called dhcp.conf where such requests could be set but alas the Fedora people clearly thought this was too simple.

    The domain is configured on the general settings page of pfsense as number36, given the satatement on the DNS Forwarder page for the Register DHCP leases in DNS forwarder :-

    If this option is set, then machines that specify their hostname when requesting a DHCP lease will be registered in the DNS

    so it seems that this backs up the wireshark traces that I did, the FC machines are not identifying themselves in the manner expected because they are very definately acquiring an IP address - verified in DHCP leases and also using ifconfig on the FC14 boxes.



  • There is an option that tells the network connection to 'Automatically obtain DNS information from provider', this option is not what you would expect, it is not the DNS server IP information.

    Using network manager (Gnome Desktop), select Network Manager (called just Network on the administration menu), double click the target connection and then leave a machine name in the 'hostname' box but uncheck the 'obtain DNS information' option then it works, the problem now is that it doesn't set any DNS server IP addresses at all.

    The fix is to leave the option selected and then add a line DHCP_HOSTNAME=whateverhostnameis into the ifcfg-eth*.conf file located in the etc/sysconfig/network_scripts folder (af least on Fedora Core) and restart the machine.

    Very intuitive !!


Log in to reply