Default gateway problems after upgrade to 2.0rc1-ipv6



  • I upgraded from 1.2.3 to 2.0rc1-ipv6 and most things works fine, but my default gateway isn't activated, I had to manually do a "route add default x.x.x.x"

    I tried removing the gateway and adding it again, but it doesn't help. Also my graph called quality seams to have stopped working, maybe this is related as it seams to ping the gateway.

    I get these logmessages regarding apinger:
    Mar 2 09:33:12 apinger: /usr/local/bin/rrdtool respawning too fast, waiting 300s.
    Mar 2 09:32:12 apinger: Error while feeding rrdtool: Broken pipe

    Any ideas on how to fix this issue?

    On another note some of my RRD-graphs seams to have lost historical data during the upgrade, but the other graphs works fine for new data after upgrade.



  • Do understand that the IPv6 support is alpha quality software at this point. Eventhough pfSense is already at 2.0-RC1 you can not consider my branch to be comparable.

    What you might have wanted to do, was upgrade from 1.2.3 to 2.0-RC1 and the proceed to my version.

    I'll have to see if there is anything in there that I can fix, but I doubt it. Normally the upgrade procedure should have taken care of that.

    You should have a gateway called GW_WAN on the routing page, and it should also be toggled default.



  • OK, didn't know I should have taken these steps. I asked sullrich on twitter if it is stable and he said: @dannew The V6 builds are sync'd with the 2.0 mainline tree so you will always have 2.0 + IPV6. It's quite stable and is what I run @ home

    No harm done though, I just added the gateway manually and I'll be fine until the next reboot :-)

    Regarding the issue:

    Yes, I have a gateway configured on the routing page, default gateway is toggled, and it's selected on the interface page for the WAN interface.

    Just to clarify, this is the pre-upgrade IPv4 configuration I have a problem with, but I'm currently trying to get IPv6 working and I have the same gateway issue for IPv6 too.



  • What is your WAN interface like? DHCP, Static?



  • It's static, otherwise I wouldn't have to configure the gateway :-)



  • That is mighty odd, that is a well supported configuration. If you have both a IPv4 gateway and a IPv6 Gateway on the WAN interface and both of them selected default it should just work.

    That makes no sense.

    Do the system logs report anything about gateway issues?



  • I don't have native IPv6 so the v6 gateway isn't on the WAN interface. I think that the gateway issue might be related to the apinger errors, as far as I understand it pfSense checks the gateway to see that it's available with apinger, and if there is a problem with the gateway it may not activate it. But these are pretty wild guesses based on the fact that manually adding a gateway works, but not from pfSense GUI.



  • you mind sending me the xml to look at? seth.mos@dds.nl



  • I have sent the config file to you, hope it helps.



  • There was a issue with the config.xml.

    The IPv6 gateway was tied to the wrong interface, the DMZ.
    The IPv6 interface was missing the defaultgw tag. Because the wrong interface was selected it probably never saved.

    If the IPv6 default gw is wrong it fails to set the IPv4 default route, that does need resolving, need to figure out why it doesn't apply first.



  • Yes, disregard the IPv6-problem for now, but currently the tunnel is terminated in the DMZ. The issue is that the v4 gateway doesn't work.



  • I've sent you a fixed config that works?



  • i got the same error. Is it possible to post the fix



  • @Kampfwurst:

    i got the same error. Is it possible to post the fix

    It still doesn't work for me, but I have added the IPv4 and IPv6 gateways manually. When I have the time I will do a fresh install and restore the configuration and see if it works better.


Log in to reply