Load Balancing



  • I have been load balancing on pfsense since 0.64 and I haven't had any problems, but today I tried to connect to a FTP and I can't. If stop using load balance pool and route to default wan everything works fine.

    Any ideas what I need to change?



  • What was the last version you know this worked on?  I assume you're now on 0.92?

    –Bill



  • Maybe these options in an upcoming version might be worth playing around with:
    http://forum.pfsense.org/index.php?topic=48.0

    But besides that help billlm to find out what's going on  ;)



  • Billm, I just tried going back to older builds, the oldest I have is 86.4 but ftp don't work when load balancing. Maybe it never worked :(

    later

    zer0-



  • Hi, this is a known bug, that I already reported on the mailing list
    The problem is with pftpx (FTP Helper), it WONT work with dual wan due to how it works, because it ties the connection to the first wan, I even tried to launch manually without telling to use the wan1 address, but neither work.
    The actual workaround is disabling the FTP Helper, that is the only way the FTP will work

    Gabriel



  • I disable ftp helper but it didnt work properly, the work around I did was to only load balance my 80 and my 119 everything else through one of the wans.


Log in to reply