Help with port forwarding on PFSense VMWare.



  • First of all hello, pfsense is a really badass program and I haven't had any problems with it yet, but I have another issue that has been on my nerves!

    I have 2 inbound connections on this computer. One wireless one wired, two seperate ISPS. I am running a VM of pfsense within Windows 7, changing my default gateway to the PFSense LAN IP and everything works great.

    On my wired network I also have an Xbox, and I use it to stream movies from my computer with. It works perfect, as they are both directly connected to the exact same router.

    The problem happens when I delete all the default routes and change it to the PFSense LAN IP 192.168.17.2 to get the Load Balancing going, my xbox is no longer able to connect to the PC although it is connected directly to the same router no more than 1 hop away? I have created 2 .BAT files to get me by, but it's annoying. One .bat file deletes all default routes and creates a default route to the pfsense lan, to enable load balancing. The second .bat is to delete all the default routes and make my DI-604 the gateway for my default route. And that works, doing that will allow me to watch movies. One or the other, not both. So I know it has something to do with the routes. I think I will need to port forward from pfsense VMware -> di-604 -> Xbox but it's so confusing. Added a picture for anyone who wants to take a stab,

    Thanks for any help. If it sounds like something you might be interesting in helping me with and need more clarification please ask I will respond asap!

    Oh and in the picture, so my setup here is my first ISP is connected by di-604. My xbox and desktop are both on that network as well, that network is 192.168.1.0/24 .
    My desktop wirelessly recieves from ISP#2 creating 192.168.0.0/24. Those two connections are both bridged through VMware via WAN & OPT1 port (Orange portion, 2 connections going to pfsense, one coming out via LAN port to my computer giving me load balance speeds.)

    Thx agin!



Log in to reply