Edits to /etc/sysctl.conf doesn't load on reboot.



  • I recently installed PFsense on an older Checkpoint UTM and it works great, except that the fan is way loud.
    I bought an inline fan controller since there's no bios settings to tune it down and its great, but I if the temp gets above 50C, the system throttles the CPU to like 75mhz out of the 600 mhz.
    if I keep the temp below 50C then the systems utilizes the full 600mhz.

    Running;
    sysctl hw.acpi.thermal

    I get;
    hw.acpi.thermal.min_runtime: 0
    hw.acpi.thermal.polling_rate: 10
    hw.acpi.thermal.user_override: 1
    hw.acpi.thermal.tz0.temperature: 48.0C
    hw.acpi.thermal.tz0.active: -1
    hw.acpi.thermal.tz0.passive_cooling: 1
    hw.acpi.thermal.tz0.thermal_flags: 0
    hw.acpi.thermal.tz0._PSV: 50.0C
    hw.acpi.thermal.tz0._HOT: -1
    hw.acpi.thermal.tz0._CRT: 60.0C
    hw.acpi.thermal.tz0._ACx: 50.0C -1 -1 -1 -1 -1 -1 -1 -1 -1
    hw.acpi.thermal.tz0._TC1: 4
    hw.acpi.thermal.tz0._TC2: 3
    hw.acpi.thermal.tz0._TSP: 60

    I added these lines to /etc/sysctl.conf and sysctl.conf.local;
    hw.acpi.thermal.user_override=1
    hw.acpi.thermal.tz0._PSV=60C
    hw.acpi.thermal.tz0._CRT=70C

    The goal would be to increase the temp when the CPU throttling would kick in from 50C to 60C.
    that way I can turn then fan speed down a bit more and not worry about the throttling.

    running the commands manually works.
    sysctl hw.acpi.thermal.tz0._PSV=60C
    hw.acpi.thermal.tz0._PSV: 60.0C -> 60.0C

    If I reboot, the settings goes back to 50C.

    If I load the sysctl script /etc/rc.d/sysctl;
    /etc/rc.d/sysctl start
    it takes the new settings.

    hw.acpi.thermal.tz0._PSV: 60.0C
    hw.acpi.thermal.tz0._HOT: -1
    hw.acpi.thermal.tz0._CRT: 70.0C

    Again if I reboot. the settings are lost again.
    I thought that Freebsd ran the scripts in the /etc/rc.d directory at boot time.
    I don't understand why it doesn't load the settings at boot but works when I manually set it.

    I've been Googling for 2 days and running out of ideas.
    Anyone know what I'm missing?

    thanks.



  • @francoisyang:

    Anyone know what I'm missing?

    pfSense regenerates a number of system configuration files from its own master config file. You need to add those entries through the web GUI at System -> Advanced, click on the System Tunables tab.



  • Thank You…that worked.
    I knew I was missing something. :)

    Thanks again.


Log in to reply