Problem to force full-duplex



  • Hello,

    I have 2 appliance with pfsense 2 (actif/passsif). I must force full duplex on WAN NIC card.
    I used the following command : ifconfig e0 media 100baseTX mediaopt full-duplex

    The new config is not applied. This is the result of ifconfig re0 :

    re0: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
    options=389b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast,wol_mcast,wol_magic>ether 00:00:24:ca:65:e1
    inet XX.XX.XX.43 netmask 0xfffffff8 broadcast XX.XX.XX.47
    inet6 ff80::200:24ffffff:65e1%re0 prefixlen 64 scopeid 0x5
    nd6 options=3 <performnud,accept_rtadv>media: Ethernet 100baseTX <full-duplex>(100baseTX <half-duplex>)
    status: active</half-duplex></full-duplex></performnud,accept_rtadv></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum,wol_ucast,wol_mcast,wol_magic></up,broadcast,running,promisc,simplex,multicast>

    I try to reboot pfsense, up/down NIC but the config is never applied.
    Someone have a idea ?

    Thank in advance !



  • On wan interface configuration at gui, you can setup speed/duplex mode



  • I have 2.0-RC1 version and the option in GUI don't exist.



  • I updated the firmware version (now i'm on 2.0.1-RELEASE).
    I have the option in interface to change the setting of NIC. I did change but is the same result : There was not applied.
    Why the change wasn't applied ?



  • That shows the config is indeed applied, it's configured that way, but the NIC refuses to use it for some reason. Not the first time I've seen that on a Realtek NIC, it's not very common, but some of those NICs cannot have their speed and duplex forced. The config setting applies, and the NIC refuses to use it. That's what you're seeing there. Is what you're plugged into really forced to 100 full? Best to always use autonegotiation if that's an option.


Log in to reply