Sarg 2.3.6 para pfsense



  • Boa Tarde Senhores,

    Estou utilizando o sarg pela primeira vez, porem não consigo nada alem do erro:
    Error: Could not find report index file.
    Check and save sarg settings and try to force sarg schedule.

    Já forcei na schedule e reinstalei o pacote.
    Quando tento obter melhores logs através do comando sarg -x tenho o seguinte retorno:

    # sarg -x
    SARG: Init
    SARG: Loading configuration from /usr/local/etc/sarg/sarg.conf
    SARG: Unknown sort criterion "SITE" for parameter "topuser_sort_field"

    Não achei nada nos foruns que pudesse me ajudar…alguem já passou por isso?
    Estou em uma Alix 2c2, verifiquei os arquivos de log em tempo real e eles estão ok, assim como os logs do squid.



  • Veja qual opção gera este erro de sort no sarg.
    Tente achar po aqui uns screenshots das minhas configurações do sarg, deve ajudar….



  • Obrigado Marcelo!

    Consegui resolver, era um problema no "User Sort Field" estava marcado para SITE, eu mudei para default e passou a funcionar perfeitamente.
    Alguem saberia dizer o que aconteceu com o Lightsquid?

    Não esta mais disponível nos pacotes?



  • Atualizei o pacote para a 2.3.6.

    A principal mudança da versão anterior para esta é correção no tratamento dos logs para o squidguard.

    att,
    Marcello Coutinho



  • Boa noite pessoal. Gostaria de deixar um feedback.
    Após seguir vários tutoriais e acompanhar diversas threads, meu sarg continuava com o problema de não gerar os relatórios do squid.

    Error: Could not find report index file.
    Check and save sarg settings and try to force sarg schedule

    O realtime funcionava, todas opções estavam marcadas corretamente (conferidas com os posts aqui do forum).
    Executando sarg -x, no final era retornado:
    Segmentation fault (core dumped)

    Consegui resolver o problema seguindo essa thread: http://sourceforge.net/p/sarg/discussion/363374/thread/ac055758/
    No meu caso foi só editar /usr/local/etc/sarg/sarg.conf e acrescentar o argumento 'bytes' em  date_time_by que estava declarada sem nada.

    TAG: date_time_by bytes|elap

    #      Date/Time reports show the downloaded volume or the elapsed time or both.

    #date_time_by bytes
    date_time_by bytes

    Isso não me parece um problema comum, posso ter errado em algum ponto sem perceber.
    Meu sarg agora está 100%, fica o feedback =) .



  • Boas…

    relativamente ao SARG é normal aparecer os ****

    ACCESSED SITE CONNECT BYTES %BYTES IN-CACHE-OUT ELAPSED TIME MILLISEC %TIME
    .***.***. 26 9.52M 53.85% 0.00% 100.00% 00:00:37 37,041 9.14%
    .***.***. 4 3.27M 18.50% 0.00% 100.00% 00:00:17 17,383 4.29%
    .***.***. 2 1.19M 6.74% 0.00% 100.00% 00:00:08 8,536         2.11%

    no meu caso eu  Report Options e no Report to generate tenho tudo seleccionado. O servidor tem espaço, é uma boa maquina, penso não ter problemas.
    nas restantes opções tenho as de default. existe algumas recomendações ?!

    um abraço



  • @Akill:

    no Report to generate tenho tudo seleccionado.

    Tudo inclusive o Privacy  :)



  • @marcelloc:

    @Akill:

    no Report to generate tenho tudo seleccionado.

    Tudo inclusive o Privacy  :)

    e os restantes campos?!Exclude Settings?? Limit Settings?? a TAB dos Users?!



  • @Akill:

    e os restantes campos?!Exclude Settings?? Limit Settings?? a TAB dos Users?!

    O que você quer? Cconfigurações recomendadas?  ???

    Se for isso, procure no tópico alguns screenshots ou sobre o sarg no google.



  • @marcelloc:

    @Akill:

    e os restantes campos?!Exclude Settings?? Limit Settings?? a TAB dos Users?!

    O que você quer? Configurações recomendadas?  ???

    Se for isso, procure no tópico alguns screenshots ou sobre o sarg no google.

    o que encontro na net penso que sejam as confg minimas… mas tudo bem, vou tentar procurar mais qq coisa...
    de qualquer maneira, sabe porque é que isto acontece?!?!

    ACCESSED SITE CONNECT BYTES %BYTES IN-CACHE-OUT ELAPSED TIME MILLISEC %TIME
    .***.***. 1 136.55K 2.62% 0.00% 100.00% 00:00:01 1,464 0.26%

    esses .***.***. ?!



  • @Akill:

    esses .***.***. ?!

    Expliquei a 2 posts atrás. Você marcou a opção Privacy.



  • Boa tarde pessoal,

    Estou com o seguinte erro no View Report:

    Error: Could not find report index file.
    Check and save sarg settings and try to force sarg schedule.

    Existe um agendamento com as opções padrão. Ao  tentar pelo shell, tenho o erro :

    SARG: Sorting file: /tmp/sarg/redirector.int_log
    SARG: (repday) Cannot open log file /usr/local/sarg-reports/14Oct2013-09Dec2013/joao/djoao.html



  • Que opções você marcou em sarg general options?



  • @marcelloc:

    Que opções você marcou em sarg general options?

    Eu olhei no tópico em inglês e vi uma screenshot sua, só funcionou depois que eu marquei todas as opções do Report do generate. Não é possível marcar só um ou outro?



  • @zilmar:

    Não é possível marcar só um ou outro?

    É sim. Eu pessoalmente marco todos.



  • @marcelloc:

    @zilmar:

    Não é possível marcar só um ou outro?

    É sim. Eu pessoalmente marco todos.

    Quando tentei da primeira vez, marquei algumas opções apenas. Depois que ele gerou esse relatório geral, foi possível gerar os individuais.



  • Boa tarde amigos!

    Parabéns pro marcelloc e a todos que contribuem para o melhoramento do SARG!

    Amigos, alguém saberia me informar se no SARG há algum relatório que me mostre os sites acessados, downloads, etc … por MAC ADDRESS ao invés de IP? Nem me interessaria o hostname do equipamento.

    Digamos que um visitante tenha acesso a uma rede wifi, e que faça acesso a sites que agora a PF precise saber das informações de MAC ADDRESS desse equipamento, pode ser um smartphone por exemplo... se essa hipotética situação ocorrer, não posso passar somente o relatório com IPs, pq esses são DHCP e não são amarrados. Alguém teria algum cenário parecido com o exemplo?



  • Mude o formato do log do squid no arquivo squid.inc

    http://www.squid-cache.org/Doc/config/logformat/



  • Eu utilizava o LightSquid e na implantação da nova versão do pfSense(2.1.3) optamos por utilizar agora o SARG.
    Fiquei com 2 dúvidas sobre o mesmo:

    1. Na opção "Proxy Server", caso eu selecione SQUID eu perco as os logs das ACLS feitas no SquidGuard? Qual o padrão colocar quando tenhos os 2 pacotes instalados(Squid3-dev e SquidGuard3)?

    2. O RealTime do LightSquid gerava o consumo de banda dos sites no exato momento de acesso. O SARG tem algum meio de habilitar isto?

    Muito obrigado!


Log in to reply