Allow default gateway switching - dual WAN



  • Hi!

    The setting "Allow default gateway switching" is located under System - Advanced - Miscellaneous.

    I have two WANs configured for load balancing. None of the interfaces has the "default gateway" set.
    The "Allow default gateway switching" is set.

    The problem is that when both WANs are connected and live there is a "default" route under "Diagnostics" - "Routes".
    When I disconnect the first WAN there is no longer a default route in the routing table.

    Shouldn't the setting "Allow default gateway switching" take care of this?

    I have even tried setting one of the interfaces as "default gateway", but still the other WAN interface doesn't get the default route when disconnecting the first WAN.

    Does anyone have some thoughts around this?



  • how do you disconnect it ? do you mean to remove the cable from the interface ? or you disable it from pfsense webConfing portal ?



  • In our experience, it works better with a Default Gateway selected.  Failover works as expected this way. :)



  • Create gateways group "System->Routing->Groups". When u creat it choose priority "tiers" of u gateways switching and trigget level "member down".
    Make the firewall rule:
    action:pass
    interface:lan
    protocol:tcp/udp
    source:lan subnet
    destination:lan subnet (AND CHECK "NOT"!!!)
    destination port range: any
    Gateway: "name of u gateways group"


Log in to reply