Developer iso installed O.K. but (automatic) bootstrap doesn't work (new problem



  • Yesterday i did a clean install of dev. iso with the latest image.
    After install i have successfully configured network and i'm writing this from behind pfsense.
    I let the dev_bootstap.sh from /usr/local/etc/rc.d/ run thru the night (it ran automatically).
    When i came to work today i checked on the progress of the build. I saw it didn't succeed.
    It took me some time to find where do you log whole process and finally found it in bootup_messages in /tmp.
    Here are only a couple of lines, while whole file can be accessed:
    http://tv.isg.si/site/ftpaccess/somebody/bootup_messages.tar.gz
    or
    http://tv.isg.si/site/ftpaccess/somebody/bootup_messages

    _…
    **** cp /usr/local/www/wizards/traffic_shaper_wizard.xml /home/pfsense/pfSense/usr/local/www/wizards/traffic_shaper_wizard.xml
    ldd: /usr/local/www/wizards/traffic_shaper_wizard.xml: not a dynamic executable
    **** cp /usr/local/www/wlan_strong_key_generator/generator.php /home/pfsense/pfSense/usr/local/www/wlan_strong_key_generator/generator.php
    ldd: /usr/local/www/wlan_strong_key_generator/generator.php: not a dynamic executable

    Installing /lib/libutil.so.5...
    Installing /lib/libc.so.6...
    ...

    Installing /lib/libc.so.6...
    Installing /lib/libc.so.6...
    Installing /lib/libc.so.6...
    Installing not...
    install: not: No such file or directory
    ..._

    There is also a problem with sftp subsystem. Try somth. like this:
    _# uname -a
    FreeBSD pfsense.local 6.2-RELEASE-p3 FreeBSD 6.2-RELEASE-p3 #0: Sun Apr 22 17:03:28 EDT 2007     sullrich@builder6.pfsense.com:/usr/obj.pfSense/usr/src/sys/pfSense_Dev.6  i386

    sftp -oPort=16 admin@localhost

    Connecting to localhost…
    The authenticity of host '[localhost]:16 ([127.0.0.1]:16)' can't be established.
    DSA key fingerprint is 53:bf:93:59:d9:85:6b:fd:c4:1b:86:17:3f:93:e7:3e.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added '[localhost]:16' (DSA) to the list of known hosts.
    Password:
    Received message too long 172040292
    #_

    Can some1 help me find the problem so i can complete the bootstrap?
    Thank you.



  • Dmesg last lines might be interesting:

    _pflog0: promiscuous mode enabled
    lock order reversal:
    1st 0xc0a79680 cdev (cdev) @ /usr/src/sys/kern/kern_conf.c:61
    2nd 0xc67d8a9c sleep mtxpool (sleep mtxpool) @ /usr/src/sys/kern/kern_prot.c:1877
    KDB: stack backtrace:
    kdb_backtrace(0,ffffffff,c0b5c5a8,c0b5c1e8,c0a031e4,…) at kdb_backtrace+0x29
    witness_checkorder(c67d8a9c,9,c0980397,755) at witness_checkorder+0x578
    _mtx_lock_flags(c67d8a9c,0,c0980397,755,c70a4700,...) at _mtx_lock_flags+0x78
    crhold(c6b96800,e937492a,e937489c,e9374bf4,e9374824,...) at crhold+0x1b
    umajor(c0a09940,0,c6b96800,0,0,...) at umajor+0x38e
    make_dev_cred(c0a09940,0,c6b96800,0,0,...) at make_dev_cred+0x21
    constty_clear(0,c6b96800,e937492a,5,e937489c,...) at constty_clear+0xd22
    devfs_allocv(e93749c4,e9374958,c6b5bc14,c0976259,299) at devfs_allocv+0xf17
    devfs_allocv(e93749c4) at devfs_allocv+0x118f
    VOP_LOOKUP_APV(c09fab00,e93749c4) at VOP_LOOKUP_APV+0x87
    lookup(e9374bcc) at lookup+0x456
    namei(e9374bcc) at namei+0x376
    vn_open_cred(e9374bcc,e9374ccc,0,c6b96800,7,...) at vn_open_cred+0x277
    vn_open(e9374bcc,e9374ccc,0,7) at vn_open+0x1e
    kern_open(c6cb3a80,bfbfdf20,0,3,0,...) at kern_open+0xb6
    open(c6cb3a80,e9374d04) at open+0x1a
    syscall(3b,3b,bfbf003b,bfbfdf2b,280e0d3d,...) at syscall+0x22f
    Xint0x80_syscall() at Xint0x80_syscall+0x1f
    --- syscall (5, FreeBSD ELF32, open), eip = 0x2833f4b3, esp = 0xbfbfdeec, ebp = 0xbfbfdf48 ---
    lock order reversal:
    1st 0xc0a581a0 pf task mtx (pf task mtx) @ /usr/src/sys/contrib/pf/net/pf.c:6386
    2nd 0xc0b9d80c tcp (tcp) @ /usr/src/sys/contrib/pf/net/pf.c:2744
    KDB: stack backtrace:
    kdb_backtrace(0,ffffffff,c0b5abb8,c0b5c7b0,c0a031e4,...) at kdb_backtrace+0x29
    witness_checkorder(c0b9d80c,9,c093f546,ab8) at witness_checkorder+0x578
    _mtx_lock_flags(c0b9d80c,0,c093f546,ab8,4,...) at mtx_lock_flags+0x78
    pf_socket_lookup(e535db00,e535db04,1,e535dbc0,0,...) at pf_socket_lookup+0x138
    pf_test_tcp(e535db70,e535db68,1,c69d9500,c6d4c700,...) at pf_test_tcp+0x592
    pf_test(1,c698d800,e535dc5c,0,0) at pf_test+0x4c1
    pfioctl(0,e535dc5c,c698d800,1,0) at pfioctl+0x3cc3
    pfil_run_hooks(c0b9d3c0,e535dcb0,c698d800,1,0) at pfil_run_hooks+0xc9
    ip_input(c6d4c700) at ip_input+0x274
    netisr_unregister(c0b9ac18) at netisr_unregister+0x11e
    netisr_queue(0) at netisr_queue+0x146
    ithread_destroy(c67f5430,c685fa80) at ithread_destroy+0xf6
    ithread_destroy(c67d68a0,e535dd38,c67d68a0,c06b4220,0,...) at ithread_destroy+0x21b
    fork_exit(c06b4220,c67d68a0,e535dd38) at fork_exit+0xd0
    fork_trampoline() at fork_trampoline+0x8
    --- trap 0x1, eip = 0, esp = 0xe535dd6c, ebp = 0 ---



  • Debugging is enabled by default in the developers iso. So you get stack traces for free.

    Plus slower performance. See if you can disable Witness in loader.conf or something or other.
    See google.



  • O.K. Cool. Nice to know where that dmesg comes from.
    But i still need to be able to build iso :-)
    Please help.



  • I still get the exact same error when building iso/bootstrap.
    Can some1 please explain to me where the problem is?



  • I still have the same problem…
    ... i did a clean install once before just to make sure it was not my fault.
    I can do it again but i don't think it will help.
    Can some1 help me?



  • try downloading a newer version and installing that or you might want to run the dev_bootstrap.sh again to see if it updates itself better.



  • O.K.
    I'll reinstall for the second time now from:
    http://snapshots.pfsense.org/FreeBSD6/RELENG_1_2/iso/developers/
    Hope this helps.

    I ran bootstrap every morning i came to work but every time build failed.



  • I tried to do the reinstall but after successful bootup i got a menu (which is different now) with error:
    Fatal Error: Call to undefined function: bindtext domain() in etc/inc/config.i
    written on the screen.

    Most of the options don't work, bunch of errors scrolls down the screen and then i get menu back. However shell does work and if i do somth like:
    echo "echo 123;" > /tmp/1.php
    php /tmp/1.php
    i get many errors most of them like:
    "PHP Warning: Unknovn(): Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20020429/*.so"

    Looks like some settings in php.ini are wrong.
    In /usr/local/lib/php/extensions/ there is another dir with more current date: 20060603 and has more .so modules in it so it might needs to be set to this one.

    With every dev. cd release it gets worse :-)



  • so did anyone figure this out then ?
    having same problem…



  • No, not a word from developers on this problem.
    As you can see they have removed the dev. iso from the web also.
    http://snapshots.pfsense.org/FreeBSD6/RELENG_1_2/iso/developers/



  • The mirrors have dev iso's from 16 May.

    http://pfsense.org/mirror.php?section=downloads/developers

    As Scott said, the dev version is unsupported by the devs.

    From experience, this kind of problem resolves itself after a few days. So, patience, grasshopper.

    ;)


Log in to reply