Darkstat, iperf & arpwatch need to have settings saved after upgrade to start up

  • Subject says it all. After a system upgade, these packages don't start again, unless one goes to their settings page and hits save.

  • Can anyone confirm if this is a bug in the package or in the system?

  • @rcfa:

    Can anyone confirm if this is a bug in the package or in the system?

    I don't think its a bug. They have been like that as far as I can remember, 1.x days.. I would say contact the maintainer but it doesn't seem listed, https://github.com/bsdperimeter/pfsense-packages/blob/master/pkg_config.8.xml

  • I've seen this in lcdproc (-dev) as well.  I always have to resave configs before LCDproc-dev, darkstat and of course Snort will startup again.  With snort, it's not so much a config save as it is forcing a re-download of the ruleset, which isn't saved/restored.

    A few others that seem to be requiring the same are Strikeback and pfBlocker.  Strikeback has always been this way, requiring that you use the "Clear log" button followed by checking the "Enable Strikeback" checkbox and saving.  pfBlocker requires that you click the "Enable pfBlocker" checkbox, then click "Save", else it doesn't go "active" after an update/upgrade.

    While these ARE livable issues for me, doing this after every update is a pain.


  • Rebel Alliance Developer Netgate

    One thing all of those packages have in common is that do not have a .inc file, they have their sync/install functions inline in their main .xml file.

    It's possible there is a package sync routine somewhere that is going by the .inc files instead of by the .xml files, if someone is curious enough, that's where I'd start

  • I have noticed this in the 2.1 snapshots where I have to now manually enable some packages such as pfblocker. The settings are saved, but the setting that enables it is not checked after upgrades.

Log in to reply