Resolve Dynamic DNS address internally?



  • Hi guys.

    I'll preface this by saying that I am DNS-Stupid.

    I have recently moved from ClearOS back to pfSense and have a quick question…

    I use dyndns.com for my dynamic dns needs.  I use RDP to remote into my desktop while I am at work and have the necessary port forwarded (ie. 7000 --> 3389).  Right now I RDP into the computername when I am at home (mycomputer) and RDP into the dyndns name + port (ie. myserver.mydomain.com:7000) when I am not on my home network.

    How can I have the dyndns name be resolved internally (when I am on my home network)?  ie. while at home on the network, RDP to myserver.mydomain.com:7000

    I know this request may seem a little odd but I do have a good reason.  I provided a VM to my wife that she could use to do some work that is not "work related" (she moonlights).  I figured this was the easiest way for her to hide it from her employer.  :)  Rather than have to provide 2 RDP shortcuts...one while she is at home (mywidesvm) and one while she is at work (myserver.mydomain.com:7001)...I would like to have just one that she can use no matter where she is.

    ClearOS seems to have the ability to do this natively but I don't know if it was because of the DNS service or the fact that I used their dynamic dns service (xxx.poweredbyclear.com).

    One more example....

    If I want to view my webserver internally, I have to visit http:\webserver.  If I try http:\myserver.mydomain.com, it fails.

    TIA!

    John


  • LAYER 8 Global Moderator

    And why would you have a problem resolving myserver.mydomain.com??

    Now if you wanted to resolve that to your local IP of I assume mywidesvm, that would be a simple host over ride.  Where your problem with that is your port 7000 to 3389 nat??

    So just forget doing anything with dns, and just turn on nat reflection.  Now when you resolve myserver.mydomain.com from inside your network you will get your public IP, when you will then hit and pfsense will reflect you back in via its nat to your privateIP:3389



  • That did it.  Like I said…DNS-Stupid.  At least now I understand NAT Reflection.  :)

    Thx john.


Log in to reply