Squidguard not blocking https



  • In the past, we blocked websites like Facebook with Squidguard (Shalla blocklist).
    Since my last update (Tue May 21) Facebook isn't blocked anymore although I block the socialnet category. This is because http://facebook redirects to https://facebook. In the past, I didn't have problems with this, but it seems since my last update, that filtering https doesn't work anymore.



  • Found time to upgrade during office times and is fixed in May 30 build.



  • Just for information:

    If your squid does not filter httpS traffic then squidguard cannot block httpS.

    In general the "transparent" option on squid only filters http (port 80). If you want to filter httpS (port 443) you need to run squid in non-transparent mode and put proxy configuration into the client's browsers.

    I know there is a new squid 3.x package which allows to filter httpS in transparent mode but you didn't mention what squid environment you use.


Locked