Gateway connection status - pending/unknown



  • The last few version of the release, the gateway connection status goes to pending and then unknown.
    The internet connection is working. The gateway IP is automatic, the gateway IP responds to pings fine.

    Version:

    2.1-RC1 (i386)
    built on Wed Aug 7 08:43:35 EDT 2013
    FreeBSD 8.3-RELEASE-p9



  • I have seen this constantly with pfsense 2.1 with many public IPs and only one gateway IP also.

    Apparently pinging 1 gateway from more than 1 interface is a no-no even when you have many public IPs and just 1 gateway.

    Seems a little arbitrary.

    What I've done in the past is either set the IP to 8.8.8.8 to ping or have them all ping each-other or just tell it not to monitor gateways.

    None of that is really good to do though, but it does make the gateway monitor turn a pretty green colour.


  • Rebel Alliance Developer Netgate

    If this worked before and only broke on snapshots from the last couple days, it could be related to some other apinger changes that are currently still being worked on.



  • Yep, it has always before, until a few RC's ago.

    Hope it gets fixed, thanks.



  • It should be fixed now, with snapshot from today (or yesterday ?). At least it's working fine for me now, no more problem with apinger (multi wan, fail over, monitor, etc …)



  • Looks like it works now, thanks for the notice, just updated.



  • Can you confirm again that things are working? I have had trouble at a site I upgraded a day or 2 ago.
    Thread: http://forum.pfsense.org/index.php/topic,65231.0/all.html



  • As of this build… it works for me.

    A few days earlier it did not.

    2.1-RC1 (i386)
    built on Tue Aug 13 13:39:48 EDT 2013
    FreeBSD 8.3-RELEASE-p9


Log in to reply