Persistent 503 on Firmware page (http://mypfsense/system_firmware.php)



  • This morning, I updated the firmware to the Wed Aug 7 20:31:48 EDT 2013 build.

    After the update had completely finished (including reinstallation of packages), I clicked the Firmware menu item, to which pfSense answered with a 503. Tried several times, the 503 was 100% reproducibly.

    I immediately felt the uncontrollable urge to get back to an earlier firmware version, so I went to the http://mypfsense/system_firmware_restorefullbackup.php page (manually via the browser's address bar, as the 503 prevented me from accessing the tabs). This page worked, and I went back to the previous build.

    Quite annoyingly, the issue persistened with the previous build, so went back to an even earlier backup (with the July 29th build).

    Extremely annyingly, the 503 insistend on popping up realibly on the system_firmware.php page even with the July 29th build - which I can definietly confirm had definitely not been the case when I had this build in production previously! Apparently, something broke which then persistend even though the firmware downgrades.

    I rebooted pfSense, and the 503 didn't care, it kept up appearing. System logs showed nothing, no crash report either.

    I figured that I had crossed the point of no return. Yep. 何者かによって、爆発物が仕掛けられたようです。 Somebody set up us the bomb. All your base are belong to us. Well, I thought, since i was going to be royally fucked anyway, I could as well use the lasted build again, clicked the link on the dashboard which lead me to the automatic update page and performed the update (this time without doing a full backup).

    Clicked the "General Setup" menu item - well, tried to, but missed, as the mouse hit an obstacle, so I landed on the Firmware page instead.

    Yup. Right. No 503. WTF! Move ZIG? For great justice?

    Well, now i'm curious why the issue has appeared in the first place, how it could survive restoration of previously working backups, and how it has myesteriously disappeared again. This whole episode might not have been a big deal, but if others start experiencing such behaviour, it might become more than a transiently disturbing issue.


  • Rebel Alliance Developer Netgate

    Browsers love to cache those kinds of things. Did you dump the browser cache at any point?
    Or shift+reload.



  • I think I used Ctrl+F5 - which should disregard the cache.

    OTOH, I was using Chrome at that time…no idea what the latest bugs are which Google included in the latest update...apart from 95% of all tabs now not rendering properly any more. However, the 503 "rendered" correctly :-)


Log in to reply