PfSense 2.1 WAN interface DHCP problem



  • I have a very basic installation of pfSense as a home firewall, using two interfaces.  It mostly works.  But twice now, in the mornings, I have found it is not routing traffic to the internet.  I am unable to ping internet hosts from the pfSense CLI.

    The first time I rebooted pfSense and that solved the problem.

    This time I did some more digging.  The WAN interface is configured to get its IP settings via DHCP (from my TimeWarner cable modem).  The WAN showed 'up' with a (seemingly) valid IPv4 address and subnet.

    I reconfigured the WAN interface via the character-based menu exactly the same (DHCP) – I just wanted to force it to refresh its IP address.  It obtained a different IP address and then everything worked.

    Where do I go from here?  I would really like to get to the bottom of this.

    FWIW pfSense is virtualized under SmartOS (KVM/qemu).

    Thank you.



  • You can probably also use the webGUI Status->Interfaces to release and renew the WAN DHCP lease.
    Sometimes if there are very short glitches in the WAN (dodgy cable, modem that goes and comes for a split second or…) then this has been known to happen, but it is rather difficult to reproduce!



  • Happy Holidays from the Newby here.

    I am having the same issue here. Use Cox Communications with Dynamic IP address. every Saturday night at midnight, the lease expires on the WAN IP and all I see are

    "apinger: ALARM: WAN_DHCP(NN.N.NN.1) *** down ***" (where the n's = the ip address up the gateway to Cox).

    The only solution for me is to reboot the PFSense Firewall.

    I am now trying a script from the following post and will keep you up to date on my progress.

    http://forum.pfsense.org/index.php/topic,17243.msg89348.html#msg89348  (or look up message # 89348 in the forum search)

    My setup is:
    2.1-RELEASE (i386)
    built on Wed Sep 11 18:16:22 EDT 2013
    FreeBSD 8.3-RELEASE-p11

    You are on the latest version.
    Platform pfSense
    CPU Type Intel(R) Atom(TM) CPU D510 @ 1.66GHz
    Current: 1257 MHz, Max: 1676 MHz
    4 CPUs: 1 package(s) x 2 core(s) x 2 HTT threads
    Using onboard adapter as wan (re0)
    Using Asus Gigabit PCI NIC as lan (re1)

    Also, I want to confirm that this is only happening on PFSENSE (version 2.1), NOT my standby $50 Asus consumer gateway, WiFi routers, nor Clear0s, m0n0wall, SmoothWall.

    I hope this helps.

    JonnyB
    SunnySD, Ca


Log in to reply