[Solved] VMWare Workstation Routing Problems



  • I'm currently having trouble getting a basic install of pfSense to route traffic from two virtual networks on VMware.  Below is the setup:

    ISP<==> Router <=Physical Network=[10.0.0.0/24]=> Physical Linux Workstation <=VMware's Default NAT (/dev/vmnet8) [10.0.8.0/24]=>pfSenseVM<=Lan Segment [192.168.200.0/24]=>Linux VM.

    I installed pfSense using the default configuration but it seems to have problems routing to the internet.  Below is some output.

    Below is an ifconfig output from a shell on the pfSense VM:

    em0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:0c:29:b0:1a:66
    	inet 10.0.8.128 netmask 0xffffff00 broadcast 10.0.8.255
    	inet6 fe80::20c:29ff:feb0:1a66%em0 prefixlen 64 scopeid 0x1 
    	nd6 options=1 <performnud>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    em1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 1500
    	options=9b <rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum>ether 00:0c:29:b0:1a:70
    	inet 192.168.200.1 netmask 0xffffff00 broadcast 192.168.200.255
    	inet6 fe80::20c:29ff:feb0:1a70%em1 prefixlen 64 scopeid 0x2 
    	nd6 options=1 <performnud>media: Ethernet autoselect (1000baseT <full-duplex>)
    	status: active
    plip0: flags=8810 <pointopoint,simplex,multicast>metric 0 mtu 1500
    enc0: flags=0<> metric 0 mtu 1536
    pflog0: flags=100 <promisc>metric 0 mtu 33144
    lo0: flags=8049 <up,loopback,running,multicast>metric 0 mtu 16384
    	options=3 <rxcsum,txcsum>inet 127.0.0.1 netmask 0xff000000 
    	inet6 ::1 prefixlen 128 
    	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x6 
    	nd6 options=3 <performnud,accept_rtadv>pfsync0: flags=0<> metric 0 mtu 1460
    	syncpeer: 224.0.0.240 maxupd: 128 syncok: 1</performnud,accept_rtadv></rxcsum,txcsum></up,loopback,running,multicast></promisc></pointopoint,simplex,multicast></full-duplex></performnud></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast></full-duplex></performnud></rxcsum,txcsum,vlan_mtu,vlan_hwtagging,vlan_hwcsum></up,broadcast,running,simplex,multicast> 
    

    A traceroute from the Linux VM to the internet:

    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
     1  pfSense.localdomain (192.168.200.1)  0.314 ms  0.182 ms  0.182 ms
     2  pfSense.localdomain (192.168.200.1)  0.223 ms  0.217 ms  0.219 ms
     3  pfSense.localdomain (192.168.200.1)  0.212 ms  0.217 ms  0.213 ms
     4  pfSense.localdomain (192.168.200.1)  0.208 ms  0.318 ms  0.593 ms
     5  * * *
     6  * * *
     7  * * *
     8  * * *
     9  * * *
    10  *^C
    
    

    A traceroute from the pfSense box to the internet:

    
    [2.1-RELEASE][root@pfSense.localdomain]/root(2): traceroute 8.8.8.8
    traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 52 byte packets
     1  localhost (127.0.0.1)  0.247 ms  0.137 ms  0.134 ms
     2  localhost (127.0.0.1)  0.165 ms  0.170 ms  0.200 ms
     3  * * *
     4  *^C
    
    

    And, finally, a traceroute from the same Linux VM as before but this time connected to the same NAT network as the pfSense VM:

    
    traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
     1  10.0.8.2 (10.0.8.2)  0.162 ms  0.108 ms  0.095 ms
     2  10.0.0.2 (10.0.0.2)  0.383 ms  0.319 ms  0.230 ms
     <snip>14  google-public-dns-a.google.com (8.8.8.8)  20.406 ms  20.233 ms 72.14.234.55 (72.14.234.55)  21.329 ms</snip> 
    

    Anyone have any ideas of what it could be?

    Thanks



  • Solved:  Turns out that sometimes if you go through the setup too fast you can end up setting the LAN interface as the default gateway …  Fix is deleting it from System: Gateways.


Log in to reply