Load balancing and sticky connections - source tracking timeout not kept



  • Hello folks,

    I'm starting using latest pfSense release, and having a look to sticky connection source tracking timeout value (System -> Advanced -> Miscellanous -> Load Balancing).
    I use load balancing with sticky connections every day, and it works fine  ;D , but I would like to increase sessions timeout.
    As I didn't want to implement phil.davis'poor man load balancing workaround (see https://forum.pfsense.org/index.php?topic=74931.msg408997#msg408997), I tried to increase the value of source tracking timeout for sticky connections. And…  ???  Once I click "Save" at the bottom of the page, the change seems to have been taken into account. But... while returning to the page later to review the value, it has disappeared.
    I tried different kinds of values (maybe I was out of range...), on different pfSense machines : same problem, the value is not kept.
    I then thought maybe it was cosmetic, and the exported the config to XML file : the value does not appear...  :'(

    Where am I wrong ? Did I miss something ?

    I think I would be able to workaround this issue once more (specifying a state timeout in the firewall rule), but what happens ?

    Thank you a lot for your help !

    Pierre



  • Ow… Ok, just understood. Specifying timeout and saving isn't enough.
    So, FYI, if needed : need to uncheck "use sticky connections", save, recheck "use sticky connections" and specify timeout, then save.
    Works nicely now  8)