[SOLVED] Alix APU 1C4 - ERROR installing on SSD



  • Hello,
    I bought a kit with APU 1C4  and  mSATA  S238 SSD SuperStore.

    The kit is recent and the disk should already have the right firmware. I do not know how to check it but on the label it says “FW: V4629N” , where “N” should identify the updated version.

    The APU firmware is the most recent: 05/04/2014

    I wanted to install pfSense on SSD so I followed the procedure I've seen several times here on the forum:

    1. I downloaded the serial memstick image    “pfSense-memstick-serial-2.1.4-RELEASE-amd64.img.gz”  (checked with md5)
    2. copied to a bootable USB pen
    3. connected with the APU serial cable and PuTTy to 115,200 bps
    4. inserted the key into the APU
    5. stopped the boot to set    kern.cam.boot_delay = "10000"
    6. Booting and changed the link to 9,600
    7. PfSense start from the USB pen and arrive to it's general menu
    8. I've configured re0/re1 and LAN  IP address
    9. So far so good, I can also connect to the webgui

    ….but…..

    10. I went back to PfSense  menu and choose the item 99  to start installation on SSD
    11.  I kept the default settings and choose to install on SSD with the "Quick / Easy Install"  menu
    12.  and then it stops with this message on the screen:

    "Execution of the command / sbin / fdisk-I ad4 FAILED with a return code of 1"
    
    

    13. ….and the message```
    "GEOM: ad4: average size does not match the tabel."

    14.  At that point I can just go out and return to the pfSense main menu.
    
    In attachement the log with the full message before/after the error  (a little cleand up).
    
    I searched here on the forum (also in pcEngines' forum) and I found some reference to similar problems, but I did not understand the possible solution.
    
    Given the error msg I thought there was a problem with the SSD but the command```
    gpart show status
    ```answers: OK.
    
    My idea is that I should first partition the SSD correctly but I don't know how to do it.
    
    Can anyone help me, please?
    
    Thank you,
    Aronese
    
    p.s. sorry for my poor english….  :(
    
    [putty-9600 for Forum - cleaned.txt](/public/_imported_attachments_/1/putty-9600 for Forum - cleaned.txt)


  • Hi guys,
    a quick follow-up to say I've solved the problem.
    The error was due to the SSD: it had a corrupted partition table. I don't know why, maybe I made some error during first attempts….. :-[
    So I rebuilt the correct geometry copying the HSC values from other post (some logs seen here on the forum).
    Having done that, the "Quick/Easy Config" tool works fine....  :)

    I write it because maybe it will be useful to others in the future.

    Bye,
    Aronese



  • Hi,

    i have the same problem.

    please can you tell me how you fix the problem. how you rebuild? which tool ? i'm new here and i have no idea what do you mean.

    thx for help!



  • what was the solution here? can someone update?


Log in to reply