N00b with install issue :(

  • After drooling over pfsense possibilities, I took plunge and bought Intel bay trail j1900 based cpu/mobo with APU and SATA HDD. I found afterwards that 2.14/2.1.5 will not even boot with this mobo! I can not return so I tried 2.2 beta CD and it booted to menu and I selected option1 to run (i never did see an option to "install to HDD"?) so when I run, it gets to this screen attached with no input of mine. Where do I go from here? Can't find any decent step by step instructions… I am total n00b with linux :( Any help is very appreciated!!!
    ![pf error.jpg](/public/imported_attachments/1/pf error.jpg)
    ![pf error.jpg_thumb](/public/imported_attachments/1/pf error.jpg_thumb)

  • You should probably go ahead and post the model number of the mobo.

    Its BSD…  Yeah.  The BSD guys will probably say its not linux.

    Often you can get these boards to boot by turning off a whole bunch of not needed features like USB3 in bios.

    Sometimes not though.  Depends on the board?  People will know better when you post the board manufacturer and model.

  • Netgate Administrator

    How is the DVD drive connected?
    And, yes, what specific board are you running?


  • Its an ASRock Q1900M. I found another thread with mobo issues for this model also. I have SATA 500GB WD drive and installing with external USB DVD drive…

    I am regretting buying this mobo...I have visions of people saying "na na na na na, your mama board on ASRock" to which I reply "my mama board don't do that no mo" LOL .. Maybe I shouldn't have been watching youtube - totally unrelated but link if you are curious- https://www.youtube.com/watch?v=38_MwcGDNhQ :)

  • Netgate Administrator

    Right, so potentially there is an issue with that board but I don't think that's what you're seeing here. Since you're booting from USB try selecting the USB option at the boot menu.


  • Yes, I selected USB from boot menu and pfsense menu comes up. I selected option 1 and it goes through about 10 seconds of text blazing across the screen but still ends up stopping at the same place as the screenshot. I also tried disabling USB3 and even serial and parallel ports in BIOS, same result :(

  • Yeah, tried again disabling almost everything in BIOS. Still stops at the same spot. Any ideas?

  • Maybe at some point, install a hypervisor and install pfsense in the hypervisor.  Might be nice in the long run because you can also install some other small VM for your use.

    I've seen that people have issues getting this up with esxi also, but I'd try virtualization if all else fails.

  • OK, I'll try that if I can't get my hands on some other hardware. Thanks for replying!

  • Trick for my machine (a while ago) was changing the SATA ports from AHCI to "Legacy" in the bios. So, more things to look at there than just "turning stuff 'off' "

Log in to reply