HAProxy does not reload after upgrade



  • Hello to all, after upgrading pfSense to 2.1.5-RELEASE (amd64) and haproxy-full from 1.4.24 pkg v 1.1.0 to 1.4.24 pkg v 1.1.1, when I apply changes made to haproxy configuration the service does not reload to apply the new configuration.
    When I do a ps -aux | grep haproxy the pid remains the same, how can I debug further?

    Thank you

    Costas



  • check if the config is valid, by running on a ssh command line:    haproxy -c /var/haproxy.conf  (i think the config file is there..). Check if that is indeed the config file containing your latest changes.

    Another thing to try could be deinstalling and reinstalling the package..

    Or take a look at the haproxy-devel package. It has more options than the other haproxy packages, and is using the currently released 1.5 version of haproxy. (make a config backup first.. as haproxy-devel might alter it.. for if you want to go back)
    It looks a bit different but should have all abilities the other packages had to..



  • Hi PiBa thank you for the reply, I noticed that the var  ${haproxy_config:="/usr/pbi/haproxy-amd64/etc/${name}.conf"} in the /usr/local/etc/rc.d/haproxy is not pointing ata the right path the config file is at /var/etc/haproxy.conf.
    When I run the config check with  /usr/pbi/haproxy-amd64/sbin/haproxy -c -f /var/etc/haproxy.cfg I got Configuration file is valid.
    So I guess I should change the path in the rc.d script and reload, right.

    Thank you



  • hi cosant,
    I dont think that script you found is actually used, when applying settings from the webgui haproxy is started by the php line in here : https://github.com/pfsense/pfsense-packages/blob/master/config/haproxy/haproxy.inc#L672

    exec("/usr/local/sbin/haproxy -f /var/etc/haproxy.cfg -p /var/run/haproxy.pid -D");
    

    So that would be looking in the correct place.
    Not sure why that doesn't work for you..

    can you start haproxy yourself with the command above? (without the exec part when trying from shell)

    Greets PiBa-NL



  • Hi PiBa no I can't start it because there is no haproxy script in that path, the config path is correct

    thank you



  • Just installing the pbi should have created a symlink for /usr/local/sbin/haproxy to the executable /usr/pbi/haproxy-amd64/.sbin/haproxy

    Can you try uninstalling and then re-installing the haproxy-full package?