Variable IP ADSL Wan connection does not activate after ISP has dropped it



  • 2.2-BETA (amd64)
    built on Fri Nov 21 08:16:06 CST 2014
    FreeBSD 10.1-RELEASE

    On a home variable ip adsl connection which can be always on but with periodic resets from the ISP to give a new IP address, the WAN connect no longer comes back on, but just shows the red cross icon. Doing a Wan save and apply changes, gets it to connect again.

    One thing I have noticed with the ISP is they will drop the connection frequently if one has been to a variety of sites which affords more privacy to the user, but when it happens its back to the wan save/apply to get net access back.

    Anything I can check to make sure something is not broken here other than upgrading to the latest version?

    TIA.



  • In pfsense for this there is a reconnection feature on pppoe.
    Otherwise seems the ISP never notifies that the link needs to renew its ip address.

    Can you show logs of the pppoe during the problem?



  • Did you try to let pfSense perform the PPPoE authentication. I prefer that method than WAN in DHCP mode.



  • @Wolf666:

    Did you try to let pfSense perform the PPPoE authentication. I prefer that method than WAN in DHCP mode.

    If this is the case is not pfSense issue but rather cable modem issue.



  • @ermal:

    @Wolf666:

    Did you try to let pfSense perform the PPPoE authentication. I prefer that method than WAN in DHCP mode.

    If this is the case is not pfSense issue but rather cable modem issue.

    Exactly, just my idea of troubleshooting.



  • @ermal:

    In pfsense for this there is a reconnection feature on pppoe.
    Otherwise seems the ISP never notifies that the link needs to renew its ip address.

    Can you show logs of the pppoe during the problem?

    I've had a look around for such a setting but cant see one. Any clues where I might find this?

    I've looked in Interfaces, Assign, PPP tab, selected the PPP but nothing like this in the entries on that page.
    Cant see anything on the WAN interface either unless you mean the Periodic Reset which is off at the moment? I did use to use this, but the ISP sometimes resets the connection within an hour so that option falls down when I have to wait 23hrs for a reset if I'm not in front of the firewall.

    Did you try to let pfSense perform the PPPoE authentication.

    Yes pf is doing the pppoe, the firewall/router is just bridging to the wan.

    txt file is attached showing the ppoe log.

    Theres a few examples in the log file of drops, but one time that did drop the connection was at 25th Nov @ 17:17, it reconnects at 17:24 when I do the Wan, Save Apply trick.

    Dont know if these mpd_wan.conf message is pertinent? I've copied the mpd_wan.conf file below.

    Nov 25 17:17:52 ppp: process 97708 terminated
    Nov 25 17:17:52 ppp: can't read configuration for "pppoeclient"
    Nov 25 17:17:52 ppp: OpenConfFile: Can't open file '/var/etc/mpd_wan.conf': No such file or directory
    Nov 25 17:17:52 ppp: OpenConfFile: Can't open file '/var/etc/mpd_wan.conf': No such file or directory
    Nov 25 17:17:52 ppp: process 92994 terminated
    Nov 25 17:17:52 ppp: [wan_link0] Link: Shutdown
    Nov 25 17:17:52 ppp: [wan] Bundle: Shutdown
    Nov 25 17:17:51 ppp: waiting for process 92994 to die…
    Nov 25 17:17:51 ppp: process 97708 started, version 5.7 (root@pfsense-22-amd64-builder 12:58 18-Nov-2014)

    mpd_wan.conf

    configure the web server

    set web close

    default:
    pppoeclient:
    create bundle static wan
    set bundle enable ipv6cp
    set iface name pppoe0
    set iface route default
    set iface disable on-demand
    set iface idle 0
    set iface enable tcpmssfix
    set iface up-script /usr/local/sbin/ppp-linkup
    set iface down-script /usr/local/sbin/ppp-linkdown
    set ipcp ranges 0.0.0.0/0 0.0.0.0/0
    set ipcp enable req-pri-dns
    set ipcp enable req-sec-dns
    #log -bund -ccp -chat -iface -ipcp -lcp -link

    create link static wan_link0 pppoe
    set link action bundle wan
    set link disable multilink
    set link keep-alive 10 60
    set link max-redial 0
    set link disable chap pap
    set link accept chap pap eap
    set link disable incoming
    set link mtu 1432
    set auth authname "myusername@myisp.com"
    set auth password mypasswordgoeshere
    set pppoe service ""
    set pppoe iface ue0
    open

    UK ISP who has stated they use 1432 for their mtu setting.

    Thanks for having a look at this.

    ppoelog.txt